Opened 11 years ago

Closed 10 years ago

#1957 closed bug (fixed)

Command Line FTP app has Name collision when connecting to an FTP site

Reported by: scottmc Owned by: axeld
Priority: low Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #3015, #3572
Has a Patch: no Platform: All

Description

When testing the FTP command line client out I noticed that in Haiku I was getting a Name collision when logging into a certain site, but when using the FTP command line client from Ubuntu to connect to that same site no such name collision occurs. Not sure if this is FTP related or if there's a mis-match of some sort with font names? Anyway, I've attached a screenshot showing a bit more detail.

Attachments (4)

screen3.png (4.1 KB) - added by scottmc 11 years ago.
ftp-screencap.png (111.9 KB) - added by scottmc 11 years ago.
even more ftp messages after recent terminal changes, this was on hrev25993
termcap.src.diff (18.7 KB) - added by oco 10 years ago.
Patch that fix this problem (maybe this should be considered a workaround)
termcap.src.2.diff (18.6 KB) - added by oco 10 years ago.
Updated patch to avoid removing comments

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by scottmc

Attachment: screen3.png added

comment:1 Changed 11 years ago by axeld

Priority: normallow

This is an issue of our termcap file when ncurses parses it.

comment:2 Changed 11 years ago by scottmc

Now the command line ftp program gives even more messages when connecting to an ftp site. I think it's something to do with the recent changes to terminal?

Changed 11 years ago by scottmc

Attachment: ftp-screencap.png added

even more ftp messages after recent terminal changes, this was on hrev25993

comment:3 Changed 10 years ago by axeld

Blocking: 3015 added

(In #3015) While it looks a bit different now, it's a duplicate of #1957.

comment:4 Changed 10 years ago by axeld

Blocking: 3572 added

(In #3572) Pretty much, someone might just have a look at that some day :-)

BTW the reason are incompatibilities between the standalone termcap implementation, and the ncurses we have.

Changed 10 years ago by oco

Attachment: termcap.src.diff added

Patch that fix this problem (maybe this should be considered a workaround)

comment:5 Changed 10 years ago by oco

From my understanding, those messages come from consistency checks when loading termcap file.

Here is what i have done to workaround the problem in offending entries :

  • put im entry before ie entry (fix "exit_insert_mode but no enter_insert_mode")
  • put empty ts entry (ts=:) when the existing one is commented (with ..) (fix "from_status_line but no to_status_line")
  • put empty Ip entry(Ip=:) when the existing one is commented (with ..) (fix "set_color_pair but no initialize_pair")

Maybe there is a way to disable those warnings in the code to avoid this.

comment:6 Changed 10 years ago by stippi

Just a question, on some swapping of the im= definition, there seems to be a change in semantics. Is this intentional? For example, it used to be empty, but is not anymore, or it used to not contain a flag and does now. I have no clue about this whole thing, so it would be really appreciated if someone who has could also have a look at this patch. Would be cool to get rid of these annoying warnings.

comment:7 Changed 10 years ago by oco

It would be unintentional. But i do not see change in im= definition in the patch. But i may overlook something in the file format (i am new in this area). Maybe, Trac formating is misleading on change at line 10984.

At least, there is a problem with two comments that should stay in the file (i will upload a new patch in a few minutes).

From my understanding, all affected terminal definitions are in the "OLDER TERMINAL TYPES" section. I am not sure one will ever use one of those terminals to connect to Haiku.

Maybe there is other way to fix this from the code (termcap, ncurses ?). I have not found where those messages are printed after a quick search. Maybe someone with a better understanding of this code base...

Changed 10 years ago by oco

Attachment: termcap.src.2.diff added

Updated patch to avoid removing comments

comment:8 Changed 10 years ago by axeld

I had two different solutions for this locally: one was to remove most entries of the termcap file, but this probably would have broken François' heart, so I couldn't do that :-)

The other was to disable the warnings in ncurses. But since this would rather be a hack, and the warnings are valid, I didn't want to commit this either.

I'm not firm in this area either, but AFAICT your patch looks fine, and is the preferred solution to this problem. Thanks! If stippi doesn't beat me to it, I will commit it tomorrow.

comment:9 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

Applied in hrev30220.

Note: See TracTickets for help on using tickets.