Opened 11 years ago

Closed 10 years ago

#2009 closed bug (invalid)

[Firefox] doesn't work on my home network

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/pre-alpha1
Keywords: Cc: mmadia, tqh
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Firefox, when installed from optional packages, doesn't start anymore. It worked a few days ago.

Attachments (2)

Haiku Firefox Segment Violation (4.3 KB ) - added by cebif 11 years ago.
tcpdump.log (5.4 KB ) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 by umccullough, 11 years ago

Cc: mmadia added

While I can't comment on the recent failure of the optional Firefox package as defined in the build system - I know that the 2.0.0.14pre re-ordered BONE version of Firefox I add to my images works just fine for me as of last night.

It would be nice if the optional package grabbed a re-ordered BONE build. I have been using the recently created 2.0.0.14pre build generated by mmadia - I don't have the URL handy. Previously I used the 2.0.0.12pre BONE image on the bebits Bleeding Edge page with good results as well. Is this a problem because of the unofficial nature of these builds still?

Hopefully the reordering will be in the official FF2 branch soon :)

comment:2 by axeld, 11 years ago

What does that mean exactly? It starts fine over here. Have you tried removing the package and download it again? Maybe something is wrong with your local version.

comment:3 by tqh, 11 years ago

Cc: tqh added

Is your image-size big enough? Other than that any output when launching from terminal, does it throw any error?

comment:4 by diver, 11 years ago

I'm using Ubuntu to compile and install to a partition (2Gb).

Here is my UserBuildConfig:

HAIKU_IMAGE_NAME        = sda7 ;                                                
HAIKU_IMAGE_DIR         = /dev ;                                                
HAIKU_ADD_ALL_OPTIONAL_PACKAGES = 1 ;

So Firefox comes from optional package. This is how I update my haiku installation: $svn up $jam

I don't know if it reinitialize this partition this way, but every file I leave on desktop disappears after such update.

I can't download another package from internet within haiku as it lacks pptp client.

Terminal only shows usual complains about stubs. I could see that firefox restarts itself upon first boot (it disappears from Deskbar and reappears again) and then it just sits in Deskbar. Ctrl+C in Terminal wont kill it, only via ProcessController.

comment:5 by diver, 11 years ago

I created vmware image with included optional packages to make sure that my bfs partition is not corrupted. Firefox don't start in vmware ether .

comment:6 by diver, 11 years ago

More info: if I disable network interface via

ifconfig /dev/net/sysconnect/0 down

Firefox loads up immediately. But after that looking at ifconfig output i see that it didn't release ip setting. Also ifconfig /dev/net/sysconnect/0 up don't make networking running again. Could this be another bug, which i should open separately?

comment:7 by diver, 11 years ago

So it seems firefox worked for me when i don't have networking (sysconnect driver). Maybe firefox tries to resolve something at boot, thinking it could connect to internet?

comment:8 by axeld, 11 years ago

This could very well be. BTW "ifconfig ... down" will only clear the IFF_UP field, it does not remove the interface or IP address. If you want to delete the interface, use "ifconfig --delete ..." instead.

Do you not have internet? Is the syskonnect driver really working for you with other applications?

I would find it a bit strange if Firefox could not run if it believes to have internet access, but doesn't. There might be some network stack problem behind this as well.

comment:9 by diver, 11 years ago

ifconfig --delete goes directly to KDL.

I don't have internet without pptp client. sysconnect driver is working ok, i used ftp to download some files from local ftp server and even used vlc to watch some videos from ftp.

I think I saw the same behavior at ubuntu once, i "ifconfig ... down" and firefox loaded too. Of course it could br very well be network stack problem. Is there anything i could try to aid debugging this problem?

comment:10 by cebif, 11 years ago

I am also having the same problem with firefox not loading. I am using firefox 2.0.0.12 bone with hrev24921 installed on its own partition. It was starting before when I was using it with hrev24521. I do get error messages if I start it from the terminal. I could show them here if it was any use.

comment:11 by cebif, 11 years ago

I get more debug information if I start firefox from a link to firefox.bin in Deskbar. It causes a segment violation. I have the UserSetupEnvironment file in /config/boot, so as to start it from firefox.bin or link to it.

by cebif, 11 years ago

in reply to:  10 comment:12 by bonefish, 11 years ago

Replying to cebif:

I am also having the same problem with firefox not loading. I am using firefox 2.0.0.12 bone with hrev24921 installed on its own partition. It was starting before when I was using it with hrev24521. I do get error messages if I start it from the terminal. I could show them here if it was any use.

This was a bug I introduced recently. It is fixed in hrev24948. It's unrelated to the problem the ticket is about, though.

comment:13 by tqh, 11 years ago

diver, if that is you full UserBuildConfig your image is not big enough. The default is only 100MB and the build script doesn't care about partition size so do increase the size in UserBuildConfig, I can't show you the exact variable, but it should be in the sample or readme version of UserBuildConfig.

You will get all kinds weirdness with apps if you try to write more than the image size. I believe there is a bug about that the build-script should fail or warn, but currently it doesn't.

comment:14 by diver, 11 years ago

Sure, i tested it several times with 500mb image inside vmware, so this is not a problem.

Some info about network settings in my place:

It is a home local network with 1000 users in. We have dhcpd server so everyone will get a ip like 172.28.xx.xx. To have an access to the internet one should use VPN (pptp) client to connect to our freebsd mpd server.

However, changing network settings in vmware do change a behavior.

By default .vmx file is set to bridged mode. In this mode my local network is working fine. ifconfig inside Haiku shows an ip 172.28.xx.xx and i could ping every server i have _inside_ my LAN, but i can't access internet.

If I change vmware to use NAT, Haiku will not have an ip and firefox loads fine. If I turn off "Connect at power on" in vmware network setting, then ifconfig will not show my nic and firefox loads fine too.

comment:15 by diver, 11 years ago

Component: ApplicationsNetwork & Internet
Summary: [Firefox] stopped working since a few revisions[Firefox] doesn't work on my home network

Still having the same issue. But it works in VirtualBox as it probably knows about ppp0 host interface. If I connect haiku on real hw to a network which doesn't need pptp authorization i can use firefox too.

comment:16 by mmadia, 10 years ago

diver : do other web browsers, eg NetSurf or Links experience this issue?

comment:17 by diver, 10 years ago

I just got a new PC and did a native install to a partition and I still have the same problems, i.e. Firefox (BeZillaBrowser now) doesn't start. I tried NetSurf and Links but they starts ok. So I tried to analyze the problem and I must say that it took me several hours.

This is what I did: I started Firefox and it hung in Deskbar as usual, so I've waited a minute and killed Firefox using ProcessController. Then I moved /boot/home/config/settings/Mozilla folder to Desktop to save it's state.

Then I turned off my nic using ifconfig /dev/net/ipro1000/0 down and started BeZillaBrowser again, and, as I expected, it started immediately. Great. So I closed firefox and moved /boot/home/config/settings/Mozilla folder to Desktop under different name for further investigation. Now I have two folders on Desktop with firefox settings.

Then I copied first folder back, launched firefox and it hung again.
Then I copied second folder back, launched firefox and it launched again.
I've repeated several times to be sure.

So I thought it must be something in this folder that prevents it from running. And I've started replacing files one by one until I've narrowed it down to prefs.js file. I then inspected this file too and found out that if I'm inserting one line of that file to the first folder I get a working firefox. So here it is:

user_pref("browser.startup.homepage_override.mstone", "rv:1.8.1.21pre");

I've even created a small shell script "fix_firefox" to help me workaround this problem:

echo 'user_pref("browser.startup.homepage_override.mstone", "rv:1.8.1.21pre");' \
>> ~/config/settings/Mozilla/Firefox/`cat ~/config/settings/Mozilla/Firefox/profiles.ini \
| grep Path |cut -c 6-`/prefs.js

So what should I do next with all this?

comment:18 by diver, 10 years ago

Maybe it tries to find the current milestone and hangs forever. see here

by diver, 10 years ago

Attachment: tcpdump.log added

comment:19 by diver, 10 years ago

tcpdump logs attached, seems like it stuck while trying to connect to mozilla.com (moz.org01.nslb.sj.mozilla.com)

comment:20 by diver, 10 years ago

ping?

comment:21 by diver, 10 years ago

Can't reproduce anymore, probably fixed with the latest firefox update. Please close.

comment:22 by tqh, 10 years ago

Resolution: invalid
Status: newclosed

Can't reproduce anymore, no longer valid.

Note: See TracTickets for help on using tickets.