Opened 11 years ago

Closed 11 years ago

#2026 closed bug (fixed)

Firefox stops connecting after a while

Reported by: stippi Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc: tqh
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Last seen on hrev24780, but had this problem ever since Firefox became usable at all. When I browse my e-mail in GMX, everything works like expected, but after a while, Firefox stops following any links I click. The "Stop" button lights up shortly, the progress bar fills quickly, but nothing happens. When I type another URL in the address bar, the same behavior, but the site is not loaded. I can quit Firefox normally, no error is displayed. When I restart it, everything works just fine again, until the error is happening again eventually. I don't know if the same error would happen when browsing other sites, I am only using GMX frequently, but the condition is reliably reached at some point.

Change History (10)

comment:1 by stippi, 11 years ago

Forgot to mention, this is with Bon Echo 2.0.0.12, R5 net_server version.

comment:2 by mmlr, 11 years ago

Are you sure this is not the known "SSL hangs" or the "redraw sometimes just stop" bugs of Firefox itself (don't know if the two are the same bug). I sometimes encounter this under BeOS too. I use F11 to quickly switch to fullscreen and back, which usually then causes the page to be drawn.

comment:3 by axeld, 11 years ago

I also have a similar problem under BeOS, but as Michael said, changing the window size then usually updates the rendering (it doesn't get correctly updated if I move another window over it, though).

comment:4 by stippi, 11 years ago

No, I don't mean that the page (window/GUI) does not update. Everything works fine, but the actual connection is not made. Firefox thinks it loaded the page, the stop button is made active and then inactive again, the progress bar zooms up to 100% and the spinning activity indicator spins shortly. Only that nothing else happens. It often happens when I click to remove a mail in GMX, the mail is then not actually removed when I connect to my mailbox in the next session. But it also happens when I click to read a mail.

comment:5 by axeld, 11 years ago

Have you tried resizing the window? Because that's exactly like it looks like over here when that happens - only the actual web view is affected, not the rest of the UI.

comment:6 by koki, 11 years ago

Have you tried the BONE version?

comment:7 by tqh, 11 years ago

Cc: tqh added

Hopefully I'll be able to do some investigation soon. As I'm using gcc4 and crosscompiling Firefox I havn't been able to have an uptime that is good enough to draw any conclusions.

comment:8 by stippi, 11 years ago

Looks a bit like with adek336's patch to #2840, I cannot reproduce this anymore. I usually got this error not too long after using Firefox for a bit, like, I couldn't check more than 30-50 mails in one Firefox session. But today, I've been using Firefox all the time in one session, working on a web page actually, so I used it quite heavily. I had another Firefox window open with my mail and checked it regularly for all day without an issue. Could the problem fixed in that patch explain such issues, or even some KDLs when using Firefox? Because I haven't got any of those today either.

comment:9 by stippi, 11 years ago

Oh, revision is hrev28589 with the patch from #2840. My uptime is currently 11h20m. NIC is ipro1000, on an SMP system.

comment:10 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

I simply cannot reproduce this anymore. It was probably fixed by one of the TCP fixes.

Note: See TracTickets for help on using tickets.