Opened 11 years ago

Closed 11 years ago

#2125 closed bug (duplicate)

DeskBar crash when drag and dropping preference folders back

Reported by: emitrax Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • Click on the leaf menu
  • Select Preference
  • In the tracker window, drag and drop the little icon on the top right onto the desktop

The Prefernce folder gets moved to the desktop, which shouldn't happen IMHO.

  • Try to drag and drop the preference folder back to the leaf submenu where it was.

Result: Deskbar crash. The stack trace says it crashed on the operator= method.

Attachments (2)

loop.jpeg (97.1 KB) - added by emitrax 11 years ago.
loop
st.jpeg (140.8 KB) - added by emitrax 11 years ago.
stacktrace

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by emitrax

Attachment: loop.jpeg added

loop

comment:1 Changed 11 years ago by emitrax

While trying to reproduce the bug I managed to create a loop in the directory as shown in the screenshot. Anyway, this is an unrelated (IMHO) issue. I can't manage to remove the screenshot. Sorry about that.

Changed 11 years ago by emitrax

Attachment: st.jpeg added

stacktrace

comment:2 Changed 11 years ago by mmlr

Resolution: duplicate
Status: newclosed

Comparing the stack crawls this is a duplicate of #478. As to moving the folder to the Desktop. This is perfectly expected behaviour. The folders in the Deskbar are not in any way special. They are just folders that happen to be located under "/boot/home/config/be". So when you do initiate a move of the folder by dragging the folders icon then this is what should happen. I suppose the loop is caused by having a link to the preference folder inside the preference folder? The same applies here, as those are just folders/files, they will behave the same as the context menu navigation in Tracker would in this case.

Note: See TracTickets for help on using tickets.