Opened 11 years ago

Closed 11 years ago

#2155 closed bug (fixed)

get_writable_cached_block: invalid block number 132376871987246 (max 6902263)

Reported by: stippi Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This bug may be a duplicate of #1120, but the stack trace is slightly different. Here it goes:

stack trace for thread 7 "low memory handler"
[snipped panic stuff]
<kernel>:get_writable_cached_block
<kernel>:block_cache_get_writable_etc
<bfs>:_FreeStaticStreamArray
<bfs>:_ShrinkStream
<bfs>:TrimPreallocation
<bfs>:bfs_put_vnode
<kernel>:free_vnode
<kernel>:dec_vnode_ref_count
<kernel>:vnode_low_memory_handler
<kernel>:call_handlers
<kernel>:low_memory
<kernel>:_create_kernel_thread_kentry

What I did:

I am copying my ZETA setup onto my Notebook which has Haiku installed. I initialized a partition for ZETA with Haiku's DriveSetup. I ftp'd the beos.zip system archive. I had unzipped that, rm -rf'd it again, because I had forgotten to create the BEOS:APP_SIG index first, unzipped it again. Then I ftp'd my zipped up home folder from ZETA and when unzipping that, I got the KDL. I used sync just before starting to unzip. The zip is not very large, about 500 Megs. The machine has 2 Gigs of RAM.

Change History (3)

comment:1 by stippi, 11 years ago

Forgot to mention: hrev25154.

comment:2 by stippi, 11 years ago

Priority: normalcritical

Forgot to give this one a proper priority.

comment:3 by axeld, 11 years ago

Resolution: fixed
Status: newclosed

I would guess this was caused by some corruption that is likely to have been fixed by now. Please reopen if it happens again.

Note: See TracTickets for help on using tickets.