Opened 11 years ago

Closed 11 years ago

#2201 closed bug (fixed)

[PATCH] Disc Time Label (fDiscTime) not long enough

Reported by: sbrokenshire Owned by: darkwyrm
Priority: normal Milestone: R1
Component: Applications/CDPlayer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using VMWare, Haiku SVN hrev25302

This is reproduced by starting CDPlayer, inserting an Audio CD (over 10 minutes long) and playing it.

Disc Time Label (fDiscTime) shows the current and total disc time but total disc time is partially shown because fDiscTime is not long enough. Expected both current and total disc time to be shown in full.

Patch attached.

Attachments (1)

CDPlayer.fDiscTimenotlongenough.diff (480 bytes) - added by sbrokenshire 11 years ago.
Patch for fDiscTime in CDPlayer

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by sbrokenshire

Patch for fDiscTime in CDPlayer

comment:1 Changed 11 years ago by stippi

Resolution: fixed
Status: newclosed

Fixed in hrev25412. I did not use your patch, because it was just another way of hardcoding the size, and it also didn't fix the potential track time truncation either. The problem was that the size calculation was based on the wrong string with regards to proportional fonts.

Note: See TracTickets for help on using tickets.