Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#2236 closed bug (fixed)

Updated AUICH driver crashes media_addon_server ...

Reported by: herdemir Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Tested with hrev25522.

I tested the updated AUICH driver(hrev25497) and it crashes media_addon_server landing to KDL.

Attachments (5)

auich_debug.log (5.3 KB) - added by herdemir 11 years ago.
AUICH log file while DEBUG enabled
auich_nodebug.log (1.9 KB) - added by herdemir 11 years ago.
AUICH log file while DEBUG disabled (from syslog)
auich_fix.diff (703 bytes) - added by herdemir 11 years ago.
auich_fixed.log (1.2 KB) - added by herdemir 11 years ago.
AUICH log after the fix (from syslog)
auich_fix_final.diff (524 bytes) - added by herdemir 11 years ago.
FINAL patch

Download all attachments as: .zip

Change History (26)

comment:1 Changed 11 years ago by herdemir

Trac doesn't allow images higher than 500k. Here is the link to the screen shot.

http://img513.imageshack.us/my.php?image=auichkdltg9.jpg

Alternate: http://img513.imageshack.us/img513/5718/auichkdltg9.jpg

comment:2 Changed 11 years ago by herdemir

Seems not related to AUICH driver ... Similar problems : #2228, #2213

comment:3 Changed 11 years ago by korli

Could you give the top of the screen (before Welcome to the kernel land) ?

comment:4 Changed 11 years ago by herdemir

Uppps! sorry ..

It should be:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x41445303, ip 0x800abcb7

If you need a new complete screenshot I can give it toworrow. As additional information:

  • It does not crash under GCC4 version of Haiku. But still cannot test the driver because of another crash which is not related to the media_server or to the driver. (Out of Topic: Should I file tickets for crashes that occours in GCC4 version, but does not occour in GCC2 version?)

comment:5 Changed 11 years ago by umccullough

My laptop (Dell Inspiron 1100 with i845 and ich4 chipset) just started to crash with the auich driver similarly as well. It just started to happen after the recent auich changes I think.

It never did work properly with the auich driver before either - making horrible noise when trying to play sound, and then a bunch of crackling sounds when I rebooted out of Haiku. I've been too lazy to report it, but now that it crashes, it's clearly something that I should report.

I can also provide some serial logs for my laptop, but not until the end of this week (since I'm out of town currently using the laptop for business).

comment:6 Changed 11 years ago by korli

Could you try again with hrev25562 please ?

comment:7 Changed 11 years ago by herdemir

It seems it is fixed, thanks. Now I tested the updated driver, but I couldn't get any sound. I looked at "Media Preferences" and saw in "AC97 mixer" that all controls were muted. (not the Audio Mixer but AC97 Mixer) So I unmuted them but there wasn't any change. Closed the Preferences windows and opened it again. And again the AC97 Mixer controls were all muted, even tough I changed them for sure. Seems it doesn't change the setting.

Changed 11 years ago by herdemir

Attachment: auich_debug.log added

AUICH log file while DEBUG enabled

Changed 11 years ago by herdemir

Attachment: auich_nodebug.log added

AUICH log file while DEBUG disabled (from syslog)

comment:8 Changed 11 years ago by herdemir

It's funny, when I enable debugging from debug.h it just works. When i disable again it brakes again. I noticed that it finds Vendor ID in DEBUG mode, but not in NON-DEBUG mode. I attached the log files.

I hope it helps ...

Tested with hrev25563.

Changed 11 years ago by herdemir

Attachment: auich_fix.diff added

comment:9 Changed 11 years ago by herdemir

Added a patch which could fix the above problem. (The fix works for me).

comment:10 Changed 11 years ago by korli

Looked in the patch. Weird, did the driver work before the ac97 regression ?

Changed 11 years ago by herdemir

Attachment: auich_fixed.log added

AUICH log after the fix (from syslog)

comment:11 Changed 11 years ago by herdemir

I didn't have any problem before the AUICH update. And also i tried several times after my fix, actually it does not fix completely. But it fixes the problem with the codec Vendor id retrival. Even tough it finds the codec id correctly sometimes i can't hear any sound.(I could hear in debug mode). Will try to increase the snooze time and see what happens.

comment:12 Changed 11 years ago by korli

I updated a bit the ac97 reset in hrev25566. Hope it can help.

Changed 11 years ago by herdemir

Attachment: auich_fix_final.diff added

FINAL patch

comment:13 Changed 11 years ago by herdemir

The last patch fixed it completely, for me.

I think the problem is after the cold reset initiated, it doesn't wait enough to finish the cold reset.

comment:14 Changed 11 years ago by herdemir

Upps didn't see your patch. will now test it ...

comment:15 Changed 11 years ago by herdemir

Works great! Thanks. :)

comment:16 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Thanks for testing and your patience :)

comment:17 Changed 11 years ago by korli

Could you check it's still working with hrev25574 ?

comment:18 Changed 11 years ago by herdemir

Tested and works fine! ;)

comment:19 Changed 11 years ago by herdemir

You seem to forgot the comma after "Philips", i think after hrev25589.

 	"ESS Technology",
 	"Harman International",
 	"Nvidea",
-	"Philips",
+	"Philips"
 	"Texas Instruments",
 	"VLSI Technology",
 	"TriTech",

comment:20 Changed 11 years ago by umccullough

Also working properly on my Dell Inspiron now (never did before!)

Thanks!

comment:21 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/AUICH
Note: See TracTickets for help on using tickets.