Opened 12 years ago

Closed 12 years ago

#2282 closed bug (fixed)

Tracker forgets settings

Reported by: kvdman Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: luroh
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using build 25714, tracker doesn't remember its settings. i.e 'show folder location in title bar', 'single window navigation' etc. If you select them, tracker behaves, upon restarting, the settings are forgotten.

Additionally, I've noticed all paths are forgotten. i.e to the development directory. Adding them in .profile remedies the situation, but I've never had to do this before.

Finally, deskbar doesn't launch properly. See the attached screenshot.

Everything mentioned 100% reproducible. Tested in Vmware.

Attachments (1)

deskbar.jpg (91.4 KB ) - added by kvdman 12 years ago.

Download all attachments as: .zip

Change History (5)

by kvdman, 12 years ago

Attachment: deskbar.jpg added

comment:1 by axeld, 12 years ago

Component: - GeneralSystem/Kernel
Milestone: R1R1/alpha1
Priority: normalcritical

I can reproduce this bug. This must be a recently introduced problem; the TrackerSettings file is just filled with zeros instead of the data it should contain. I guess Deskbar has the same issue.

comment:2 by kvdman, 12 years ago

It happened after rev25562, I don't know where exactly. I tested a new revision six days after and incurred the problem.

comment:3 by luroh, 12 years ago

Cc: luroh added

I think I have traced the deskbar problem to hrev25620 but it could do with some more testing, see ticket #2260 (contains links to vmware image files).

comment:4 by axeld, 12 years ago

Resolution: fixed
Status: newclosed

Thanks luroh, that was very helpful, the problem was indeed hrev25620! Fixed in hrev25747.

Note: See TracTickets for help on using tickets.