Opened 11 years ago

Closed 7 years ago

Last modified 2 weeks ago

#2296 closed bug (invalid)

No graphics on i916G, black screen after boot screen.

Reported by: hugen Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc: HubertNG@…
Blocked By: #7662 Blocking:
Has a Patch: no Platform: x86

Description

I have Asus A3H, Haiku displayed significantly on this graphics once, flickering screen from some time is already only.

Cel M 1.6 GHz 768 MB RAM i915 GMA

Attachments (14)

DSC00126.JPG (91.6 KB) - added by hugen 11 years ago.
DSC00127.JPG (95.0 KB) - added by hugen 11 years ago.
DSC00128.JPG (90.6 KB) - added by hugen 11 years ago.
DSC00129.JPG (93.8 KB) - added by hugen 11 years ago.
DSC00130.JPG (85.5 KB) - added by hugen 11 years ago.
DSC00131.JPG (82.7 KB) - added by hugen 11 years ago.
DSC00132.JPG (80.8 KB) - added by hugen 11 years ago.
DSC00133.JPG (78.5 KB) - added by hugen 11 years ago.
DSC00134.JPG (83.0 KB) - added by hugen 11 years ago.
DSC00135.JPG (79.0 KB) - added by hugen 11 years ago.
DSC00137.JPG (49.6 KB) - added by hugen 11 years ago.
DSC00138.JPG (74.0 KB) - added by hugen 11 years ago.
DSC00139.JPG (77.3 KB) - added by hugen 11 years ago.
r35580syslog.txt (15.2 KB) - added by kallisti5 9 years ago.

Download all attachments as: .zip

Change History (30)

Changed 11 years ago by hugen

Attachment: DSC00126.JPG added

Changed 11 years ago by hugen

Attachment: DSC00127.JPG added

Changed 11 years ago by hugen

Attachment: DSC00128.JPG added

Changed 11 years ago by hugen

Attachment: DSC00129.JPG added

Changed 11 years ago by hugen

Attachment: DSC00130.JPG added

Changed 11 years ago by hugen

Attachment: DSC00131.JPG added

Changed 11 years ago by hugen

Attachment: DSC00132.JPG added

Changed 11 years ago by hugen

Attachment: DSC00133.JPG added

Changed 11 years ago by hugen

Attachment: DSC00134.JPG added

Changed 11 years ago by hugen

Attachment: DSC00135.JPG added

Changed 11 years ago by hugen

Attachment: DSC00137.JPG added

Changed 11 years ago by hugen

Attachment: DSC00138.JPG added

Changed 11 years ago by hugen

Attachment: DSC00139.JPG added

comment:1 Changed 11 years ago by axeld

That's currently expexted, as the Intel driver does not yet support laptop panels.

comment:2 Changed 11 years ago by axeld

Component: Drivers/GraphicsDrivers/Graphics/intel_extreme

comment:3 Changed 11 years ago by jackburton

Is this still valid ? AFAIK The intel driver does support laptop panels, now.

comment:4 Changed 10 years ago by Hubert

Cc: HubertNG@… added

I tested last time with USB and work correctly, but problem was with resize resolution. I still tested.

comment:5 Changed 10 years ago by Hubert

I tested now: boot with USB work correctly, boot with CD: black screen - I need use safe video mode with save boot to boot further.

comment:6 Changed 10 years ago by kallisti5

Booting using intel_extreme with a i915G video card on an Optiplex GX280 causes blacked out screen as of hrev33027. Booting from VESA works fine though.

syslog shows i915G, revision = 0x4

comment:7 Changed 10 years ago by umccullough

Is #4240 potentially a duplicate of this?

Would be interesting to know if you can enter KDL from the "black screen" and see a backtrace?

comment:8 Changed 9 years ago by kallisti5

Summary: no display graphicsNo graphics on i916G, black screen after boot screen.

can't KDL, keyboard non-responsive on hrev35580 with i916G

Attaching a serial output of syslog.

Noticed something strange though, the "i965 quirk" gets noted on the i916G chipset.. looking at the intel_extreme driver this gets triggered to fix some kind of bug on intel chips (http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/graphics/intel_extreme/intel_extreme.cpp#L260) . Is it safe to use this patch on the i916G?

Changed 9 years ago by kallisti5

Attachment: r35580syslog.txt added

comment:9 Changed 9 years ago by axeld

It's probably not a good idea to apply it, but it's relatively unlikely to cause real harm.

comment:10 Changed 8 years ago by scottmc

Blocking: 7662 added

comment:11 Changed 7 years ago by kallisti5

Hugen, could you test in a recent nightly? The Intel Extreme driver has seen several changes which may correct edge cases such as these.

comment:12 Changed 7 years ago by Hubert

Hey. I haven't now that model of laptop but on intel 965 and boot with USB work properly.

Last edited 7 years ago by Hubert (previous) (diff)

comment:13 Changed 7 years ago by korli

Hubert, are you the original reporter (hugen)?

comment:14 in reply to:  13 Changed 7 years ago by Hubert

Replying to korli:

Hubert, are you the original reporter (hugen)?

That's right.

comment:15 Changed 7 years ago by korli

Resolution: invalid
Status: newclosed

Closing

comment:16 Changed 2 weeks ago by waddlesplash

Blocked By: 7662 added
Blocking: 7662 removed
Note: See TracTickets for help on using tickets.