Opened 10 years ago

Closed 9 years ago

#4240 closed bug (duplicate)

Black screen after boot splash when using intel_extreme driver

Reported by: koki Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/alpha1
Keywords: Cc: umccullough, kallisti5
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a PC with the intel integrated video (82945G/GZ Integrated Graphics Controller rev 02, according to lspci) hooked via an analog connection to a Sumsung 22" wide screen.

Haiku will boot in VESA mode, but then I cannot set the resolution to when I try to use the intel_extreme driver, all I get is a black screen right after the Haiku boot splash.

Screenshot of backtrace taken from KDL attached.

Attachments (1)

2009-08-14_black-boot-screen.jpg (135.2 KB) - added by koki 10 years ago.
Backtrace from KDL

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by koki

Backtrace from KDL

comment:1 Changed 10 years ago by koki

Sorry, in the second paragraph of the description I meant to say: "Haiku will boot in VESA mode, but then I cannot set the resolution to 1680 x 1050. And when I try to use the intel_extreme driver, all I get is a black screen right after the Haiku boot splash."

comment:2 Changed 10 years ago by umccullough

Cc: umccullough added

Having a similar issue with my new Foxconn atom 330-based machine containing an i945 chipset as well.

Boots fine in "fail safe video" mode, but intel_extreme seems to die. After rocket icon, screen goes black for a second, then goes back to a weird offset image of the bootsplash again and hangs.

Dropping into KDL sometimes shows the picasso thread active with a backtrace ended in the accelerant exactly like the screenshot posted by koki.

comment:3 Changed 10 years ago by kallisti5

Cc: kallisti5 added
Version: R1/pre-alpha1R1/alpha1

I have had the same issue (black screen after boot splash) on the following systems:

Dell Optiplex GX620 (Intel GMA945) Dell Optiplex GX280 (Intel 915)

VESA works fine though.

Thanks!

comment:4 Changed 10 years ago by umccullough

This looks like probably a duplicate of #3464 and #3149

comment:5 Changed 10 years ago by koki

FWIW, here is the relevant listdev output on my hardware:

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2772: 82945G/GZ Integrated Graphics Controller

comment:7 in reply to:  description ; Changed 9 years ago by Michael S.

I tried more than 50 builds (from R1/a1 33104 to Walter 34190) - with all from them right after jogs of all icons there is a black screen. It will be sometime corrected? Similar bug it is described here: http://dev.haiku-os.org/ticket/4811 and it has the status "fixed". These video cards almost identical, differ only device id (27a2 - 2772).

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2772: 82945G/GZ Integrated Graphics Controller

comment:8 in reply to:  7 Changed 9 years ago by Michael S.

And syslog it has not time to be created - when the black screen the computer completely hangs.

comment:9 Changed 9 years ago by axeld

Blocked By: 3149 added
Resolution: duplicate
Status: newclosed

comment:10 Changed 9 years ago by axeld

Blocked By: 3149 removed
Note: See TracTickets for help on using tickets.