Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#230 closed bug (fixed)

Missing "sticky" mode in menus

Reported by: diver Owned by: jackburton
Priority: high Milestone: R1
Component: - General Version:
Keywords: Cc: kutspam@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is a long standing and a very very annoying bug, one have to alwayes hold mouse button in popup menu(BMenuPopup?).

Change History (16)

comment:1 Changed 13 years ago by jackburton

It's not exactly a bug but a missing feature.

comment:2 Changed 13 years ago by axeld

Owner: changed from axeld to jackburton

comment:3 Changed 13 years ago by jackburton

Summary: no need to hold mouse button in popup menusMissing "sticky" mode in menus

comment:4 Changed 13 years ago by marcusoverhagen

"click to open" menu mode is available in BeOS R5. In haiku it doesn't work. Thats no feature :/ This is really annoying when using a notebook with touchpad.

comment:5 Changed 13 years ago by jackburton

Exactly, it's a feature not yet implemented in haiku,.

comment:6 Changed 13 years ago by j_freeman@…

Semantics, guys, it's just semantics.

Bottom line is it's not working the way it works in R5. Call it a bug, a missing feature, or whatever... To end-users it's all the same. ;)

The only reason I'd like to see it "fixed" or added or whatever is that it is, as Diver said, long-standing and *very* annoying. Of course, I know there are others things that take higher priority but to some testers--this one in particular--it would just make testing all that much easier.

...just my two pence. :)

comment:7 Changed 13 years ago by diver

(In reply to comment #4)

I know there are

others things that take higher priority but to some testers--this one in particular--it would just make testing all that much easier.

...just my two pence. :)

I totally agree with this.

comment:8 Changed 13 years ago by marcusoverhagen

Cc: marcus@… added

comment:9 Changed 13 years ago by axeld

Cc: nutela@… added

comment:10 Changed 13 years ago by axeld

* Bug 399 has been marked as a duplicate of this bug. *

comment:11 Changed 13 years ago by jackburton

Status: newassigned

comment:12 Changed 13 years ago by jackburton

I implemented a somewhat working sticky mode since hrev17042. I think nonsticky mode is currently broken, though. I'd like some help on testing and fixing what's broken.

comment:13 Changed 13 years ago by diver

WOW! Thanks, Stefano! Much better now.

Things to check: try to hold your mouse in the desk shelf (above time) for several seconds to bring calendar window. After it will show up it will instantly close.

comment:14 Changed 13 years ago by jackburton

Resolution: fixed

comment:15 Changed 13 years ago by jackburton

Status: assignedclosed

comment:16 Changed 13 years ago by jackburton

I'm closing this bug as sticky mode is implemented now. Other problems related to menus should be filed as separate bugs.

Note: See TracTickets for help on using tickets.