Opened 11 years ago

Closed 11 years ago

#2419 closed bug (fixed)

[app_server] don't react on mouse events after moving Cortex window

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

From Terminal /boot/beos/demos/Cortex
Window->Full Palettes.
Start moving main Cortex window around and in the same time switch workspaces.

After some time you can't move any window or click anywhere, but mouse moves and ProcessController is alive.

Change History (4)

comment:1 by diver, 11 years ago

Summary: [app_server] don't react on mouse events after moving Cortwx window[app_server] don't react on mouse events after moving Cortex window

comment:2 by humdinger, 11 years ago

In vmware, hrev27404, I cannot reproduce this.

I do get all kinds of redrawing artefacts from Cortex' window and weirdly trailing palettes on all windows beneath them. It all goes back to normal once those freaky palettes have settled down. I guess the "Pulling" of the palettes is quite CPU expensive. In any case, if diver or others can't reproduce either, I guess the ticket can be closed.

comment:3 by julun, 11 years ago

Hi,

can you please check if this is still valid with the latest image, i could not reproduce anything like that. Otherwise i would close the ticket.

Thanks, Karsten

comment:4 by julun, 11 years ago

Resolution: fixed
Status: newclosed

I can't reproduce this anymore at least since hrev27881.

Note: See TracTickets for help on using tickets.