Opened 11 years ago

Closed 11 years ago

#2511 closed bug (fixed)

MediaPlayer will not play .wav files from an Audio CD

Reported by: Bouncer Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I did a search for this problem. And found a single match in the comments given for hrev21153. With not even a TODO.

So - if only to make sure this problem is tracked, and not forgotten, here it is again.

a) MediaPlayer gives an error if directly accessing the wav file on the Audio CD.

b) If the wav file is dragged to the desktop. It is then playable by MediaPlayer.

This is on real hardware. SATA DVD Rom drive. Intel HD Audio sound.

Change History (4)

comment:1 Changed 11 years ago by anevilyak

Component: - GeneralApplications/MediaPlayer
Owner: changed from axeld to marcusoverhagen

I can confirm this one as well on the latest revs.

comment:2 Changed 11 years ago by axeld

Component: Applications/MediaPlayerFile Systems/cdda
Owner: changed from marcusoverhagen to axeld

That's more likely the reason.

comment:3 Changed 11 years ago by anevilyak

I'm trying to understand how cdda-fs would cause that problem though, unless it's failing block reads from the decoder sniffers. Otherwise it seems as if the file being on BFS is giving MediaPlayer some extra information that it's used in lieu of the sniffers and it's not falling back gracefully in the absence of said info, or something along those lines. Would need to investigate exactly what call is failing in MediaPlayer in this case to be sure though. I also need to check what mime type cdda reports for those files as opposed to what they get identified as once copied to BFS. This problem is at least 100% reproducible though.

comment:4 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev26853.

Note: See TracTickets for help on using tickets.