Opened 11 years ago

Closed 8 years ago

#2512 closed bug (fixed)

vlc does not play either wav or mp3 files.

Reported by: Bouncer Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On real hardware. With Intel HD Audio.

The VLC player puts out extremly distorted sound.

Basically - its no sound at all most of the time But every second or so - a tiny window opens up for maybe just 50 or 100 ms - and you hear a tiny burst of sound. The sound bursts come in slightly faster than once per second. Over a 20 second interval - I counted 22 or 23 of them.

The volume and tone of these tiny sound bursts also seem to correlate with the natural rythym of the music that was being played.

For comparision. MediaPlayer plays the same files very well. Without any distortion at all.

Change History (5)

comment:1 Changed 11 years ago by axeld

I guess you are using the OpenSound HD Audio driver? Have you tried disabling MMX/SSE support in VLC and see if that helps?

comment:2 Changed 11 years ago by stippi

This may be a bug in VLC when the buffer size and respectively latency is so high, or it may be a bug in our BSoundPlayer implementation (also about big buffers/latency). I remember Francois mentioned in IRC that he had to decrease the OSS buffersize to make VLC work. It's not a bug in the OSS code though. Either VLC or the Haiku code that VLC uses, I think BSoundsPlayer or whatever it was called... :-)

comment:3 Changed 10 years ago by mmadia

any updates on this?

comment:4 Changed 9 years ago by scottmc

Can you retry this with a fresher build of Haiku? there's been some fixes to the HDA driver since this ticket was first reported.

comment:5 Changed 8 years ago by scottmc

Resolution: fixed
Status: newclosed

This one has probably been fixed.

Note: See TracTickets for help on using tickets.