Opened 11 years ago

Closed 10 years ago

#2545 closed bug (fixed)

[kernel] GeForce MX420 lots of stability issues

Reported by: diver Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Recently I changed my noname GeForce4 MX440 with Albatron GeForce4 MX420 I've got all sort of random problems.

"(card A)" 10de:0181 (rev 02) 01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a4) 
"(card B)" 10de:0172 (rev a3) 01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 420] (rev a3) 

Boot logo appeared with "Input is unsupported" message from monitor, though boot logo was just fine. Several seconds later media_addon_server crashed.

Thread 144 called debugger(): Can't register system time source
[Switching to team /boot/beos/system/servers/media_addon_server (144) thread media_addon_server (144)] 0xffff0102 in ?? ()
(gdb) bt
#0  0xffff0102 in ?? ()
#1  0x005255f6 in debugger () from /boot/beos/system/lib/libroot.so
#2  0x002063e0 in MediaAddonServer::ReadyToRun ()
#3  0x002b1965 in BApplication::DispatchMessage ()  from /boot/beos/system/lib/libbe.so
#4  0x002bc011 in BLooper::task_looper () from /boot/beos/system/lib/libbe.so
#5  0x002b01dd in BApplication::Run () from /boot/beos/system/lib/libbe.so
#6  0x002087e6 in main ()
(gdb) 

Only Terminal and Deskbar have been loaded and ProcessController showed constant cpu loading.
I typed "top" in terminal and media_server and fxp intr handler (I have an Intel nic) both used 50% of cpu time.
With 1st (card A) I never saw this problems.
USB mouse didn't work, even after hot replug.
Also fonts looked a little better than with 1st card which i described in #2415.
Could this font corruption be caused by some combination of modern wide screen and old GeForce card?

Then I created new tab in terminal and at this point app_server freezed. I was able to access kdl via F12. Then I rebooted and selected "Use fail-safe video" option, this didn't change anything.
When I switched (card B) with (card A), all problems are gone. Also surface of (card B) was very hot. Ubuntu is working stable with this graphic card.

Change History (9)

comment:1 by diver, 11 years ago

I don't know which component this ticket should be assigned, so please do. I would like to help with investigation, so feel free to ask me to do more testing.

comment:2 by anevilyak, 11 years ago

Component: - GeneralDrivers/Graphics/nVidia

comment:3 by anevilyak, 11 years ago

Owner: changed from axeld to rudolfc

Reassigning to Rudolf so he can check if it is in fact an nvidia driver issue.

comment:4 by mmlr, 11 years ago

The fxp interrupt handler taking up all the CPU time was reported in bug #2084 already. Interesting is that this only happens with a specific setup of the mentioned cards here. This might hint into the direction of interrupt handling in the shared/non-shared case. I doubt that it's an nVidia problem in that case and would rather think it's caused by the ipro100 driver (that the fxp interrupt handler belongs to). Could you check the output of the "ints" command in KDL and also check what IRQs are assigned to the cards in each configuration. You can find that in the early part of the syslog where the PCI info is dumped. Check the "interrupt_line" of both devices, the graphics card and the network card to see if they are the same with either configuration.

comment:5 by rudolfc, 10 years ago

Hi there,

I doubt this is an nvidia driver issue..

Bye!

Rudolf.

comment:6 by rudolfc, 10 years ago

Hi,

Is this problem still current? Otherwise I'd like to close this ticket since it's unlikely to be a nvidia problem (tested a number of nvidia cards working together, two at a time in my systems which went all OK..)

Bye!

Rudolf.

comment:7 by diver, 10 years ago

Feel free to close this ticket as I will have this PC only after 6 months.

comment:8 by rudolfc, 10 years ago

OK, thanks!

closing the ticket.

Bye!

Rudolf.

comment:9 by rudolfc, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.