Opened 11 years ago

Closed 11 years ago

#2756 closed bug (fixed)

r27664 breaks booting on previously working system with panic re being unable to find boot partition

Reported by: anevilyak Owned by: bonefish
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Attached syslog contains complete details of the boot run, though immediately suspicious to me is:

KDiskDeviceManager::_Scan(/dev/disk)
KDiskDeviceManager::InitialDeviceScan() failed: No such file or directory

Attachments (2)

syslog.txt (35.4 KB) - added by anevilyak 11 years ago.
syslog_vfs_tracing.txt (41.0 KB) - added by anevilyak 11 years ago.
Additional syslog with VFS tracing enabled, if at all useful.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by anevilyak

Attachment: syslog.txt added

comment:1 Changed 11 years ago by umccullough

I can confirm breakage here on my Optiplex GX270 with a PATA disk and Haiku booting from 2nd partition.

It works with 27663, fails with 27664.

I can provide an additional serial log provided if needed.

comment:2 Changed 11 years ago by anevilyak

Milestone: R1R1/alpha1
Priority: normalcritical

Changed 11 years ago by anevilyak

Attachment: syslog_vfs_tracing.txt added

Additional syslog with VFS tracing enabled, if at all useful.

comment:3 Changed 11 years ago by anevilyak

On second thought, maybe it's this?

Could not load "scsi_cd" error -2147459069
Could not load "scsi_disk" error -2147459069

comment:4 Changed 11 years ago by luroh

This happens with hrev27664 when I build to a second partition on my disk, but it boots fine if I build to just a single partition instead.

comment:5 Changed 11 years ago by anevilyak

Note: my Haiku partitions are (and has always been) on partitions 2 and 3 as well (partition 1 = FreeBSD).

comment:6 Changed 11 years ago by luroh

Having tested some more, Haiku seems to have a problem booting from multi-partition disks. Building to the first of several partitions does not help. Only building to a single partition disk works for me with hrev27664.

comment:7 in reply to:  3 Changed 11 years ago by anevilyak

Replying to anevilyak:

On second thought, maybe it's this?

Could not load "scsi_cd" error -2147459069
Could not load "scsi_disk" error -2147459069

FYI, with the latest change I get malloc errors before both of these:

0x00105938 Partition::_Mount check for file_system: BFS Filesystem
load kernel...
video mode: 1280x1024x32
malloc(): Out of memory!
Could not load "scsi_cd" error -2147459069
malloc(): Out of memory!
Could not load "scsi_disk" error -2147459069

comment:8 Changed 11 years ago by bonefish

Replying to anevilyak:

On second thought, maybe it's this?

Could not load "scsi_cd" error -2147459069
Could not load "scsi_disk" error -2147459069

I encountered that too while working on the changes for hrev27664. It turned out that the boot loader ran out of heap (the error message is not very helpful). My changes to the BFS code simply caused it to use more memory, since it now loads full blocks instead of only the inode structures. The problem disappeared again when changed the code to let streams share blocks. Maybe it's a bit configuration depended whether the heap limit is hit.

Anyway, I increased the heap size in hrev27680. Please verify, whether that fixes the problem.

comment:9 Changed 11 years ago by anevilyak

Resolution: fixed
Status: newclosed

Just confirmed, hrev27680 fixes it indeed. Now I encounter ticket #2757 though.

Note: See TracTickets for help on using tickets.