Opened 11 years ago

Closed 7 years ago

#2796 closed bug (fixed)

File size of new file from template not updated

Reported by: humdinger Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #4703, #8767
Has a Patch: no Platform: All

Description

This is on vmware, hrev27404.

I created a text template with

touch /boot/home/config/settings/Tracker/Tracker\ New\ Template/Text

and assigned text/plain via the FileType Add-on.

Now I create a new text file in /boot/home/ with the "New..." menu using this template. Open the new text file in StyledEdit, write some text and save.

The size is still shown as "0". Terminal gives the correct size. The size is only updated after closing and reopening the folder.

Change History (8)

comment:1 by axeld, 11 years ago

I can easily reproduce this, also under BeOS; seems to be a genuine Tracker bug.

comment:2 by anevilyak, 11 years ago

Maybe it's forgetting to set up the node monitor on that node in this particular case? That's the only thing I can think of offhand since this implies it's not getting B_STAT_CHANGED for that file.

comment:3 by humdinger, 10 years ago

Blocking: 4703 added

(In #4703) Although having a bit more general info, this is a duplicate of #2796. I close it a dup, or should the older ticket be marked as dup of this one?

comment:3 by humdinger, 10 years ago

Same as #4703.

comment:4 by humdinger, 7 years ago

Blocking: 8767 added

comment:5 by stpere, 7 years ago

Owner: changed from axeld to stpere
Status: newin-progress

comment:6 by anevilyak, 7 years ago

Version: R1/pre-alpha1R1/Development

comment:7 by stpere, 7 years ago

Resolution: fixed
Status: in-progressclosed

fixed in hrev44400. thanks!

Note: See TracTickets for help on using tickets.