Opened 11 years ago

Closed 11 years ago

#2968 closed bug (duplicate)

PackageInstaller crash with personalStudio

Reported by: miqlas Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I tested personalStudio that i downloaded from BeShare (personalStudio_1.5_en_tri.pkg) on Haiku R28283. It installed correctly but ont the end of the install process the PackageInstaller give an error massage: "The application PackageInstaller encountered an error..."

I get this in the debugger:

(gdb) bt #0 0xffff0104 in ?? () #1 0x006ac4b6 in debugger () from /boot/beos/system/lib/libroot.so #2 0x006b56d9 in assert_fail () from /boot/beos/system/lib/libroot.so #3 0x006bdc4e in BPrivate::hoardHeap::freeBlock ()

from /boot/beos/system/lib/libroot.so

#4 0x006becfa in BPrivate::processHeap::free ()

from /boot/beos/system/lib/libroot.so

#5 0x006c0431 in free () from /boot/beos/system/lib/libroot.so #6 0x006aa5b0 in builtin_delete () from /boot/beos/system/lib/libroot.so #7 0x002177fb in PkgDirectory::~PkgDirectory () #8 0x0021758b in pkg_profile::~pkg_profile () #9 0x00211a74 in PackageInfo::~PackageInfo () #10 0x0020e28b in PackageView::~PackageView () #11 0x0020dd2a in PackageWindow::~PackageWindow () #12 0x002d6fa6 in BLooper::Quit () from /boot/beos/system/lib/libbe.so #13 0x0038101e in BWindow::Quit () from /boot/beos/system/lib/libbe.so #14 0x0020dd7a in PackageWindow::Quit () #15 0x0020e8ef in PackageView::MessageReceived () #16 0x002d6b3f in BLooper::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#17 0x003838b1 in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#18 0x003870a8 in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #19 0x002d809b in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so ---Type <return> to continue, or q <return> to quit--- #20 0x006b08fc in thread_entry () from /boot/beos/system/lib/libroot.so #21 0x78102fec in ?? ()

Change History (1)

comment:1 by anevilyak, 11 years ago

Resolution: duplicate
Status: newclosed

duplicate of 2969 but more info there.

Note: See TracTickets for help on using tickets.