Opened 11 years ago

Closed 10 years ago

#2992 closed bug (fixed)

BMenuBar redraw issue (missing update the arrow when enlarging)

Reported by: julun Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: jackburton, stippi
Blocked By: Blocking: #2740, #2977, #2989
Has a Patch: no Platform: All

Description

Using a BMenuField in an layout enabled Haiku app, it does not get properly redrawn while resizing. The code that prevents updating the menu arrow region is in BMCPrivate.cpp, _BMCMenuBar_::Draw(BRect updateRect) starting at line 137, end at 151. I can't even see a need for that code, as the arrow area is drawn on top of the menu anyway.

Change History (4)

comment:1 by jackburton, 11 years ago

Owner: changed from axeld to stippi

You mean the ConstrainClippingRegion() part ? Maybe it was used to avoid unnecessary redrawing. Reassign to Stephan as he certainly know what was for.

comment:2 by julun, 11 years ago

Blocking: 2977 added

(In #2977) Seems to depend on #2992 as well.

comment:3 by idefix, 10 years ago

I think this bug is fixed as I can't reproduce #2740, #2977 and #2989 with hrev32063.

comment:4 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

Yes, this one is fixed. Thanks for the update/reminder.

Note: See TracTickets for help on using tickets.