Opened 11 years ago

Closed 10 years ago

#3048 closed bug (fixed)

IO Scheduler: "no more requests" panic

Reported by: heto Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #3404
Has a Patch: no Platform: x86

Description

Running Haiku hrev28387, I frequently (often several times a day) get PANIC: no more requests in the IO scheduler thread. There does not seem to be a reliable way to reproduce the bug; I have had it occur even immediately after the system has booted and Tracker has loaded, although usually the bug occurs after a couple hours of usage.

I'll attach a log with a backtrace. The backtrace always stops at a READ FAULT right after IOScheduler::_Scheduler, so it might not be very useful. I have a couple of blurry photos from earlier occurrences of the panic, and looking at them it seems that the arguments to IOScheduler::_Scheduler are always the same for the most part.

Attachments (3)

no_more_requests_log.txt (1.4 KB) - added by heto 11 years ago.
backtrace from the panic
no-more-requests.r28506.trimmed.txt (1.4 KB) - added by heto 11 years ago.
no-more-requests-R1Alpha1.jpg (88.8 KB) - added by idefix 10 years ago.
backtrace of the 'no more requests' panic

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by heto

Attachment: no_more_requests_log.txt added

backtrace from the panic

comment:1 Changed 11 years ago by axeld

Can you please retry with a current revision? I have never seen this panic, and more recent revisions have the "read fault" problem in the stack traces fixed.

comment:2 Changed 11 years ago by heto

I updated to hrev28506, but still get the READ FAULT. In fact, I got three identical panics on the three first boots to the new revision before the post_install scripts had even finished (or at least they were run again on the next boot). I'll attach a trimmed serial log showing only one panic; I have the full serial log of the three boots if needed, though.

I installed Haiku under R5 by initialising the partition using R5 tools and copying the files from a haiku-files pre-alpha image to the Haiku partition also under R5. Maybe R5 lays out the files on the disk differently from bfs_shell and Haiku BFS driver and thus provokes the bug?

Changed 11 years ago by heto

comment:3 Changed 10 years ago by idefix

I just encountered the same problem with Haiku R1Alpha1 while updating the tree.

backtrace of the 'no more requests' panic

Changed 10 years ago by idefix

backtrace of the 'no more requests' panic

comment:4 Changed 10 years ago by axeld

Owner: changed from axeld to bonefish
Version: R1/pre-alpha1R1/Development

comment:5 in reply to:  4 Changed 10 years ago by idefix

Replying to axeld:

  • version changed from R1/pre-alpha1 to R1/Development

I have only encountered this panic with R1/alpha1, because I have never run svn update on a newer revision. Will do so from now on and hopefully encounter this bug again in the coming months...

comment:6 Changed 10 years ago by bonefish

Resolution: fixed
Status: newclosed

Should be fixed in hrev34655.

comment:7 Changed 10 years ago by bonefish

Blocking: 3404 added

(In #3404) That's a duplicate of #3048 and fixed in hrev34655.

Note: See TracTickets for help on using tickets.