Opened 10 years ago

Last modified 5 years ago

#3098 reopened bug

[SoundRecorder] don't add unsupported files to playlist

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you drop any non audio file on SoundRecorder it will show error (which should be changed to be more clear btw) and then adds it to playlist. This also activates Save button, which it shouldn't do.

Change History (15)

comment:1 Changed 10 years ago by diver

Summary: [SoundRecorder] don't add unsupported icons to playlist[SoundRecorder] don't add unsupported files to playlist

comment:2 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed

Could you check with hrev28574 ? It should be fixed (the item is removed when not supported). The error messages should be better in hrev28576.

comment:3 Changed 10 years ago by diver

Resolution: fixed
Status: closedreopened

comment:4 Changed 10 years ago by diver

I still can drag many unsupported files (see timezone files) and it will not reject those.

comment:5 Changed 10 years ago by diver

Oh and "No handler. [8000411b]" is not what I would expect. "Cannot recognize this file as media file" alone would be good enough.

comment:6 Changed 10 years ago by korli

Please check again with hrev28613.

comment:7 Changed 10 years ago by diver

I still can drag some files to it like ActivityMonitor.

comment:8 Changed 10 years ago by korli

Please check again with hrev28660.

comment:9 Changed 10 years ago by diver

List of files which SoundRecorder thinks it could handle:

urlwarpper
route
makebootable
libnetsync_plugin.avi
libdvdcss.so
ftpd
Deutsch.de.addon

comment:10 Changed 9 years ago by diver

Still here in hrev35572.

comment:11 in reply to:  10 Changed 9 years ago by bonefish

Version: R1/pre-alpha1R1/Development

Replying to diver:

Still here in hrev35572.

Thanks for going through all those tickets! I would be nice, if you could also update the "Version" field of those tickets still present in the current version.

comment:12 Changed 9 years ago by diver

Will do.

comment:13 Changed 5 years ago by Barrett

I've tested it under the latest rev, and it seems unsupported filed are handed correctly, with a proper message showing. So i suppose the ticket could be closed.

comment:14 Changed 5 years ago by diver

Still the case with libdvdcss.so, traceroute and ftpd.

comment:15 Changed 5 years ago by Barrett

i tried to solve that adding a control on the BMediaFile media_file_format, but it seems that binaries are recognized as fruible media by some media plugin. So it seems the problem isn't SoundRecorder itself.

Note: See TracTickets for help on using tickets.