Opened 11 years ago

Closed 10 years ago

#3099 closed bug (fixed)

BePDF KDLs on exit

Reported by: kvdman Owned by: laplace
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #3588
Has a Patch: no Platform: All

Description

Testing BePDF on Haiku, it will crash inconsistently when exiting the application. You'll see when you close it (if it doesn't KDL), that it is still running in the taskbar. If you try and kill it with process controller you'll KDL as well. This was testing without reading any file, and appears to be new as of one week... See attached.

Attachments (1)

1.jpg (187.9 KB) - added by kvdman 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by kvdman

Attachment: 1.jpg added

comment:1 Changed 11 years ago by kvdman

I should add, Haiku hrev28544, BePDF 1.1.1.

comment:2 Changed 10 years ago by anevilyak

Blocking: 3588 added

(In #3588) Indeed, thanks!

comment:3 Changed 10 years ago by stippi

Owner: changed from axeld to laplace

I haven't seen BePDF KDL on exit, but it consistently "hangs". That is, it's actually still functional, because you can double click PDFs and they will open in BePDF. I think it's still the same instance.

The hang is caused by the main application thread waiting for the two "OutputTracer" threads. These are apparently supposed to log stdio and stderr output (of xpdf?). Both of these threads are blocking in the respective read() call. I think what happens is that the stdio/stderr file descriptors are not being deleted at this point in time, and BePDF makes a wrong assumption about the order in which the teardown happens on program exit. Or BePDF is correct and there is a bug in Haiku. To investigate, just hit F12, type "teams", find the BePDF team, type "threads #BePDF team id#", and type "sc #each thread id#" to see the "deadlock".

comment:4 Changed 10 years ago by modeenf

I tested to start and close BePDF in hrev31406 and I hade no problem.Can I close this one?

comment:5 Changed 10 years ago by kvdman

Seems resolved, please do.

comment:6 Changed 10 years ago by modeenf

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.