Opened 10 years ago

Closed 9 years ago

#3267 closed bug (fixed)

Tracker context menu interprets mouse move as click

Reported by: Adek336 Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc: planche2k@…, mdisreali@…
Blocked By: Blocking: #5770, #5778
Has a Patch: no Platform: All

Description

Select a big amount of files. Right click. Quickly move the mouse to the place where the context menu will appear a split second later. Do not click. The context menu's "Open" item will be invoked just like if it was clicked.

Change History (21)

comment:1 Changed 9 years ago by andreasf

Cc: planche2k@… added

comment:2 Changed 9 years ago by diver

You can even delete files accidentally this way. Shouldn't this has a higher priority?

comment:3 Changed 9 years ago by humdinger

Andreas added in a duplicate ticket #5770:
When right-clicking a tab in Terminal it is sometimes immediately closed, too. At BeGeistert it was assumed to be a general menu issue.

comment:4 Changed 9 years ago by anevilyak

Blocking: 5778 added

comment:4 Changed 9 years ago by anevilyak

Blocking: 5778 removed
Owner: changed from axeld to anevilyak
Status: newin-progress

comment:5 Changed 9 years ago by anevilyak

Version: R1/pre-alpha1R1/Development

Should be fixed in hrev36443.

comment:6 Changed 9 years ago by anevilyak

Blocking: 5770, 5778 added

comment:7 in reply to:  3 ; Changed 9 years ago by andreasf

Replying to humdinger:

When right-clicking a tab in Terminal it is sometimes immediately closed

Still with us at hrev36443.

comment:8 in reply to:  7 ; Changed 9 years ago by anevilyak

Replying to andreasf:

Still with us at hrev36443.

Looking into it, can you confirm better behavior for Tracker's context menus though?

comment:9 in reply to:  8 ; Changed 9 years ago by andreasf

Replying to anevilyak:

can you confirm better behavior for Tracker's context menus [...]?

Yes, better. Thank you!

comment:10 in reply to:  9 ; Changed 9 years ago by anevilyak

Replying to andreasf:

Yes, better. Thank you!

Terminal's case should be fixed in hrev36453, please verify.

comment:11 Changed 9 years ago by diver

I could still reproduce this bug in vbox. If I right-click on the desktop and move mouse-cursor to where menu will appear it will select some menu item. hrev36474.

comment:12 Changed 9 years ago by diver

Also reproducible with PowerStatus replicant in deskbar.

comment:13 Changed 9 years ago by Disreali

Cc: mdisreali@… added

comment:14 in reply to:  10 Changed 9 years ago by andreasf

Replying to anevilyak:

Terminal's case should be fixed in hrev36453, please verify.

Terminal's case seemed resolved, but now has reappeared at hrev36576.

comment:15 Changed 9 years ago by anevilyak

Hm, can no longer reproduce it here. The problem is that to an extent it's not perfectly solvable right now, due to the (very poorly designed) BMenu API we have to keep compatibility with. As a consequence of that design, BMenu operates by using input polling, which has the unfortunate side effect that it can completely miss events. Its code for menu tracking is as a consequence a mess, since it also has to try to handle the cases for all the different types of menus. Some of these problems are nearly impossible to fix without reworking the API in a way that would most certainly break compatibility, you can see signs of this in R5 as well (menu keyboard navigation is more or less completely unusable since the mouse tracking interferes with it).

comment:16 Changed 9 years ago by diver

comment:11 still reproducible for me in hrev36595.

comment:17 Changed 9 years ago by anevilyak

Status: in-progressassigned

Won't have time to look into this further until earliest the weekend, releasing in the meantime if someone else wants to give it a try.

comment:18 Changed 9 years ago by anevilyak

Does hrev36607 help at all with the Tracker problem?

comment:19 Changed 9 years ago by diver

Great, can't reproduce it anymore. It seems it also fixed #3373.
Should I open another ticket about PowerStatus context menu issue?

comment:20 Changed 9 years ago by anevilyak

Resolution: fixed
Status: assignedclosed

Yes please, since those are different apps, and this was ultimately fixed in Tracker itself. Ditto for the terminal tab issue please, will see if I can't find another way to fix that one. Thanks for the feedback!

Note: See TracTickets for help on using tickets.