Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#3348 closed bug (fixed)

[Terminal] Selecting the same font in preferences causes "Save changes?" dialog

Reported by: diver Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc: rossi@…
Blocked By: Blocking: #3891
Has a Patch: no Platform: All

Description

Open Terminal preferences and select the same font. Now if you click Ok you will be asked to save changes. BTW, shouldn't there be Defaults and Revert buttons insted Ok and Cancel like in other preflets?

Change History (5)

comment:1 by rossi, 11 years ago

Cc: rossi@… added

comment:2 by axeld, 10 years ago

Blocking: 3891 added

(In #3891) I guess we're all getting senile :-) Duplicate of bug #3348 - always a good idea to look for those bugs first.

comment:3 by stpere, 10 years ago

Owner: changed from jackburton to stpere
Status: newassigned

comment:4 by stpere, 10 years ago

Resolution: fixed
Status: assignedclosed

Hi,

I fixed this in hrev32421. I don't know about the second part of your ticket, maybe someone can enlight me if that would be better?

comment:5 by humdinger, 10 years ago

The second part ties in with the comment in #4198

  • The OK button and also the alert regarding unsaved changes when closing the prefs panel aren't needed, all settings are live.

Though, IMO it's enough to have a "Revert" button that goes back to the setting when the preference panel was opened.

Note: See TracTickets for help on using tickets.