Opened 10 years ago

Closed 10 years ago

#3392 closed bug (duplicate)

PANIC: vm_page_fault: unhandled page fault in kernel space at 0xdeadbf2b, ip 0x80568f26

Reported by: umccullough Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/TCP Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #2706 Blocking:
Has a Patch: no Platform: All

Description

Looks like I got a very similar issue to #2706 (where there is much more info apparently) - it's probably a duplicate but I'm logging separately just in case (feel free to close as such if necessary).

This is using a gcc4-built hrev29087 with an rtl8168 network chip.

Crash apparently occurred unattended after ~24 hours of uptime with Vision running in the background, and dnetc consuming CPU cycles (and probably communicating with the dnetc server for short periods of time every few hours).

Was able to extra info by hooking up the serial cable:

kdebug> info
kernel build: Jan 28 2009 20:32:09
SVN revision: 29087

cpu count: 2, active times:
  [1] 42504899790
  [2] 42050265531
pages:          294418 (521888 max)
sems:           1515 (131072 max)
ports:          140 (4096 max)
threads:        137 (4096 max)
teams:          19 (2048 max)
kdebug> message
vm_page_fault: unhandled page fault in kernel space at 0xdeadbf2b, ip 0x80568f26

kdebug> bt
stack trace for thread 86 "/dev/net/rtl8169/0 consumer"
    kernel stack: 0x805b9000 to 0x805bd000
frame               caller     <image>:function + offset
 0 805bc8e4 (+  32) 8005ac4a   <kernel_x86> invoke_debugger_command() + 0x00de
 1 805bc904 (+  48) 8005ad86   <kernel_x86> _ZL19invoke_pipe_segmentP21debugger_command_pipelPc() + 0x0083
 2 805bc934 (+  32) 8005ae4e   <kernel_x86> invoke_debugger_command_pipe() + 0x008b
 3 805bc954 (+ 128) 8005e567   <kernel_x86> _ZN16ExpressionParser17_ParseCommandPipeERi() + 0x0aa3
 4 805bc9d4 (+  48) 80060d03   <kernel_x86> _ZN16ExpressionParser15EvaluateCommandEPKcRi() + 0x06d5
 5 805bca04 (+ 192) 80060e81   <kernel_x86> evaluate_debug_command() + 0x0089
 6 805bcac4 (+  80) 8005955a   <kernel_x86> kernel_debugger() + 0x02ca
 7 805bcb14 (+ 160) 800596ac   <kernel_x86> panic() + 0x002a
 8 805bcbb4 (+  80) 800ac840   <kernel_x86> vm_page_fault() + 0x00ff
 9 805bcc04 (+  64) 800b8237   <kernel_x86> page_fault_exception() + 0x00db
10 805bcc44 (+  12) 800bb236   <kernel_x86> int_bottom() + 0x0036
kernel iframe at 0x805bcc50 (end = 0x805bcca0)
 eax 0x810a2898     ebx 0x8056e144      ecx 0x806460fc   edx 0xdeadbeef
 esi 0x8064617c     edi 0x0             ebp 0x805bcd38   esp 0x805bcc84
 eip 0x80568f26  eflags 0x10286
 vector: 0xe, error code: 0x0
11 805bcc50 (+ 232) 80568f26   </boot/beos/system/add-ons/kernel/network/protocols/ipv4> _Z21ipv4_send_routed_dataP12net_protocolP9net_routeP10net_buffer() + 0x004f
12 805bcd38 (+ 112) 807c705e   </boot/beos/system/add-ons/kernel/network/protocols/tcp> _ZN11TCPEndpoint11_SendQueuedEbm() + 0x0484
13 805bcda8 (+  32) 807c72aa   </boot/beos/system/add-ons/kernel/network/protocols/tcp> _ZN11TCPEndpoint15SendAcknowledgeEb() + 0x0026
14 805bcdc8 (+  48) 807c97d0   </boot/beos/system/add-ons/kernel/network/protocols/tcp> _ZN11TCPEndpoint15SegmentReceivedER18tcp_segment_headerP10net_buffer() + 0x00b0
15 805bcdf8 (+ 208) 807c58f1   </boot/beos/system/add-ons/kernel/network/protocols/tcp> _Z16tcp_receive_dataP10net_buffer() + 0x0314
16 805bcec8 (+ 160) 8056ad21   </boot/beos/system/add-ons/kernel/network/protocols/ipv4> _Z17ipv4_receive_dataP10net_buffer() + 0x066c
17 805bcf68 (+  48) 8055831a   </boot/beos/system/add-ons/kernel/network/stack> _ZL22domain_receive_adapterPvP10net_deviceP10net_buffer() + 0x0033
18 805bcf98 (+  64) 80558139   </boot/beos/system/add-ons/kernel/network/stack> _ZL22device_consumer_threadPv() + 0x0095
19 805bcfd8 (+  32) 80050abc   <kernel_x86> _ZL28_create_kernel_thread_kentryv() + 0x0015
20 805bcff8 (+2141466632) 800542f0   <kernel_x86> _ZL19thread_kthread_exitv() + 0x0000
kdebug>

Machine is still running and sitting in KDL. If there is any further useful info that can be obtained - let me know.

Attachments (3)

haiiku_r29071_gcc4_rtl8168_kdl.jpg (313.9 KB) - added by umccullough 10 years ago.
image of KDL in rtl8168 consumer thread
haiku_r29087_gcc4_rtl8168_kdl.txt (3.0 KB) - added by umccullough 10 years ago.
crash serial output info
ipv4_crash_r29228.txt (4.0 KB) - added by umccullough 10 years ago.
Another crash on hrev29228

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by umccullough

image of KDL in rtl8168 consumer thread

Changed 10 years ago by umccullough

crash serial output info

Changed 10 years ago by umccullough

Attachment: ipv4_crash_r29228.txt added

Another crash on hrev29228

comment:1 Changed 10 years ago by umccullough

Another crash on gcc2 Haiku hrev29228 - with a nicer looking stack trace - crash initiated from Vision.

comment:2 Changed 10 years ago by axeld

Resolution: duplicate
Status: newclosed

Duplicate of #2706.

Note: See TracTickets for help on using tickets.