Opened 10 years ago

Closed 5 months ago

#3394 closed bug (fixed)

[Beam] slow repainting on resize

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: zooey
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you resize Beam window it will take several seconds here (virtualbox) to repaint beam window. It looks like a problem with liblayout and app_server.

Attachments (1)

beam-1-1-2-r5.zip (1.6 MB) - added by diver 7 years ago.
Beam with all libraries bone

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by stippi

It seems to behave normal on real hardware here.

comment:2 Changed 9 years ago by diver

Still here in hrev35141 in VirtualBox 3.0.12

comment:3 Changed 9 years ago by diver

Typo: hrev35141 should be hrev35569.

comment:4 Changed 9 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:5 Changed 8 years ago by diver

Still present in hrev39716.

comment:6 Changed 7 years ago by diver

Cc: zooey added

Still reproducible in hrev44040 on real hw.

Changed 7 years ago by diver

Attachment: beam-1-1-2-r5.zip added

Beam with all libraries bone

comment:7 Changed 5 years ago by diver

Beam 1.0 doesn't have this problem whereas it's there starting with version 1.1. Maybe it's an application bug after all? Need to test it in BeOS.

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 5 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Now only takes about a quarter to half a second, and watching CPU usage shows that it's all in Beam, not in app_server; so that combined with the fact that Beam 1.0 does not have this issue, the remaining parts must have been a Beam issue.

Note: See TracTickets for help on using tickets.