Opened 13 years ago

Closed 12 years ago

#355 closed bug (fixed)

[Tracker] slow content loading

Reported by: diver Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: Applications/Tracker Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

Tracker is slow when loading files in icon view or mini icon view. To reproduce open haiku volume from desktop and press alt+2 to switch to miniicon mode and close this window. Open it again and go to /boot/beos/bin. It will take 20 seconds to show content.

Tested with freshly downloaded rev16908 under vmware.

Change History (10)

comment:1 Changed 13 years ago by diver

This manipulation also deadlock appserver. It happens to me already several times.

comment:2 Changed 13 years ago by korli

bug_group: developers

comment:3 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Priority: normalcritical

comment:4 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:5 Changed 12 years ago by nielx

Component: - Applications- Applications/Tracker

Correct component.

comment:6 Changed 12 years ago by aldeck

Can't reproduce anymore here, hrev23150 on VMWare Fixed?

comment:7 Changed 12 years ago by scottmc

I just rechecked it in hrev23287 following the method listed above and it still goes slow as was first reported. This was on real hardware, my test laptop a Thinkpad 570E.

comment:8 Changed 12 years ago by aldeck

Indeed, i could reproduce it consistently on real hardware and vmware, but only with a fresh image/install.

Apparently, if you already (even after a reboot) visited a directory in mini icon mode before doing the above steps, then the bug doesn't show.

Example steps: a- Start with a _fresh_ haiku image or install b- Go to boot/beos/bin c- Switch to mini icon view (no bug here) d- Close the window

From there, you can't reproduce the orignal ticket's bug. The bug appears with boot/beos/system boot/beos/apps etc.. until you visited them one time, even after a reboot.

Can you confirm this?

hope this helps, alex

comment:9 Changed 12 years ago by axeld

Status: newassigned

Definitely! I investigated the problem a bit, and it occurs because Tracker cannot read the "pose info" attribute from the files and retries 10 times for each time - with a timeout of 10 ms between each try. I have no idea why this doesn't happen on BeOS yet (don't have a BeOS machine here right now :-().

comment:10 Changed 12 years ago by axeld

Resolution: fixed
Status: assignedclosed

ixed in hrev23376. What were they thinking??? :-)

Note: See TracTickets for help on using tickets.