Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#356 closed bug (fixed)

ShowImage Dithering

Reported by: alex.jussow@… Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version:
Keywords: Cc: diver, leavengood
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

Make a screenshot. Open in ShowImage. Turn on Dithering. Open a menu or move another window over the ShowImage window.

The screenshot gets corrupted.

Change History (7)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by leavengood

I could not reproduce this on the latest version of ShowImage running in BeOS R5. Is this possibly only a bug on Haiku?

The steps I took:

  1. Take a screenshot with the PrintScreen button.
  2. Open that screenshot in ShowImage.
  3. Turn on dithering.
  4. Open menus, move other windows over the ShowImage window, all drawing looks fine.

In addition, the Dither menu item may be removed (for me it makes the image look worse.)

comment:3 Changed 13 years ago by leavengood

This is probably related to #527, which seems to be a problem with the Haiku app_server.

comment:4 Changed 13 years ago by korli

bug_group: developers

comment:5 Changed 13 years ago by axeld

Component: ApplicationsUser Interface/app_server
Description: modified (diff)
Owner: changed from sikosis to stippi
Platform: All

comment:6 Changed 12 years ago by leavengood

Resolution: fixed
Status: newclosed

I just tested the latest ShowImage on the latest Haiku image and this does not seem to be a problem anymore.

comment:7 Changed 12 years ago by axeld

Cc: leavengood added

Bummer. What did you change that may have done the trick? As this was obviously an app_server problem, I don't the think the actual cause of the problem has been fixed yet.

Note: See TracTickets for help on using tickets.