Opened 13 years ago

Closed 13 years ago

#365 closed bug (invalid)

nv.driver loading aswell as vesa

Reported by: johndrinkwater Owned by: rudolfc@…
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver, umccullough
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

Bootup log claims the nv.driver is loaded, but vesa loads after it(?) from the logs,

mga.driver: init_hardware() failed: General system error nm.driver: init_hardware() failed: General system error module: Search for bus_managers/agp/v0 failed. loaded driver /boot/beos/system/add-ons/kernel/drivers/dev/graphics/nv.driver Radeon - init_hardware: Version: 5.1.0.1 Radeon - Radeon_CardDetect: no supported devices found radeon.driver: init_hardware() failed: General system error vesa: init_hardware() vesa: init_driver() vesa: publish_devices() vesa: find_device() loaded driver /boot/beos/system/add-ons/kernel/drivers/dev/graphics/vesa

Change History (4)

comment:1 Changed 13 years ago by rudolfc@…

Hi,

This bug might not be a bug after all. For instance, during driver development I am using Vesa and 'real' driver together at the same time on numerous occasions.

Maybe I should state this differently: Having the option to combine Vesa mode and the driver is/might be desirable for driver development. From a user's perspective it's confusing, I agree.

During normal startups I think Vesa mode drivers should indeed _not_ be loaded. At this point however, there might be Haiku dependancies here: some parts might be needing the Vesa interface (still), while that should not be in the end of course.

I think the person most suited to answer these questions is probably Axel.

Axel, what do you think???

thanks!

Rudolf.

(leaving status as is for now)

comment:2 Changed 13 years ago by diver

Cc: diver added

comment:3 Changed 13 years ago by umccullough@…

Cc: umccullough@… added

comment:4 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Resolution: invalid
Status: newclosed

This is actually not a bug: when the app_server scans for the graphics drivers, both drivers see hardware they support. The app_server will just know that it shouldn't load the VESA driver. When we port over the drivers to the new driver architecture, the hardware will no longer be available for the VESA driver, though, and thus it won't be visible any longer.

Note: See TracTickets for help on using tickets.