Opened 10 years ago

Closed 10 years ago

#3832 closed bug (duplicate)

KDL on NFS Mount

Reported by: egrath Owned by: mmu_man
Priority: normal Milestone: R1
Component: File Systems/NFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When mounting a remote NFS share you immediatly get into KDL:

nfs: mount(4, <NULL>, 00000000)
nfs: nfs_params: nfs:10.138.23.214:/shared,uid=0,gid=0,hostname=haiku
nfs:ip!
IP:10.138.23.214
nfs:hn!
nfs:uid!
nfs:gid!
nfs: ip:0a8a17d6 server:'10.138.23.214' export:'/shared' hostname:'shredder' uid=0 gid=0 
nfs: mountd at d6178a0a:53010
nfs: nfsd at d6178a0a:2049
vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x15, ip 0x84b54d93, write 0, user 0, thread 0x8b
PANIC: vm_page_fault: unhandled page fault in kernel space at 0x15, ip 0x84b54d93

Welcome to Kernel Debugging Land...
Thread 139 "w>Desktop" running on CPU 0

This occurs on a fresh installation of Haiku R30452 (also tested on older builds). The command used to mount was:

mkdir /shared
mount_nfs linux:/shared /shared 0 0

When doing a TCPDUMP on the Server side, the following is sent before crashing:

13:42:11.319722 IP haiku.1023 > nelson.health.local.sunrpc: UDP, length 92
13:42:11.319845 IP nelson.health.local.sunrpc > haiku.1023: UDP, length 28
13:42:11.323176 IP haiku.1023 > nelson.health.local.sunrpc: UDP, length 92
13:42:11.323570 IP nelson.health.local.sunrpc > haiku.1023: UDP, length 28
13:42:11.326250 IP haiku.1023 > nelson.health.local.53010: UDP, length 88
13:42:11.327197 IP nelson.health.local.53010 > haiku.1023: UDP, length 60
13:42:11.327568 IP haiku.3 > nelson.health.local.nfs: 108 getattr [|nfs]
13:42:11.327662 IP nelson.health.local.nfs > haiku.3: reply ok 96 getattr DIR 40755 ids 0/0 [|nfs]
13:42:11.328308 IP haiku.4 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.328387 IP nelson.health.local.nfs > haiku.4: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.328499 IP haiku.5 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.328575 IP nelson.health.local.nfs > haiku.5: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.328917 IP haiku.6 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.328992 IP nelson.health.local.nfs > haiku.6: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.329174 IP haiku.7 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.329249 IP nelson.health.local.nfs > haiku.7: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.335511 IP haiku.8 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.335587 IP nelson.health.local.nfs > haiku.8: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.336748 IP haiku.9 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.336824 IP nelson.health.local.nfs > haiku.9: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.337496 IP haiku.10 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.337573 IP nelson.health.local.nfs > haiku.10: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683
13:42:11.338642 IP haiku.11 > nelson.health.local.nfs: 108 fsstat [|nfs]
13:42:11.338719 IP nelson.health.local.nfs > haiku.11: reply ok 48 fsstat tsize 8192 bsize 4096 blocks 18123552 bfree 10902307 bavail 9981683

The configuration of the NFS server (/etc/exports):

/shared 	haiku(rw,no_root_squash,no_subtree_check)

Change History (1)

comment:1 by mmu_man, 10 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3500.

Note: See TracTickets for help on using tickets.