Opened 10 years ago

Closed 10 years ago

#3862 closed bug (fixed)

Shutdown doesn't wait for user input

Reported by: zooey Owned by: axeld
Priority: high Milestone: R1/alpha1
Component: Servers/registrar Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you have StyledEdit and/or Mail open with a changed document and then select shutdown from the deskbar menu, the respective alerts asking whether or not to save the document appear, but only for a couple of seconds, then the system proceeds to shut down.

Expected behaviour would be to wait until the user answers the dialog (possibly showing an additional hint that the application may be waiting for that answer).

I've seen this in VMware with both gcc2 and gcc4 builds.

Change History (6)

comment:1 by jonas.kirilla, 10 years ago

I´ve seen this too.

comment:2 by stippi, 10 years ago

Sounds like the change to Deskbar, which toggles a boolean in the message to Registrar should be reverted, and instead the Registrar should be changed to not display the alert. Alertnatively, the Registrar shutdown API should be changed, so that "wait for user input" and "display confirmation alert" are two separate things.

comment:3 by jonas.kirilla, 10 years ago

I tried toggling that boolean back. The confirmation alert is back of course, but StyledEdit and Mail still can´t successfully halt the reboot process even though their save/cancel/dont save dialogs do show up. But Pe is able to halt the shutdown, so it could be that StyledEdit and Mail are not doing things right. I had a brief look at StyledEdit but didn´t see anything obviously wrong.

comment:4 by axeld, 10 years ago

The registrar only checks whether or not the application is waiting on a modal panel. Maybe there is something wrong with how it detects this, or StyledEdit/Mail actually aren't using a modal panel for this.

comment:5 by axeld, 10 years ago

Owner: changed from bonefish to axeld
Status: newassigned

Hm, interesting: actually BPrivate::is_app_showing_modal_window() is currently not implemented, and always returns true. IOW the registrar should currently never quit an app without questioning - looks like there is an actual bug hidden.

comment:6 by axeld, 10 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev30788.

Note: See TracTickets for help on using tickets.