Opened 10 years ago

Closed 4 weeks ago

#3888 closed bug (fixed)

[Tracker] file list flickering on window resize

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc: stippi
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

To reproduce:

  • Leaf menu->Find...[Enter]
  • While list is populating start windows resizing.
  • You should see lots of flickering here.
  • When population is done there will no more flickering.

Attachments (1)

screenshot1.png (208.4 KB ) - added by diver 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by diver, 10 years ago

Using binary search i've tracked it down to somewhere between hrev30012 (didn't have a problem) and 30048
svn log --revision 30012:30048 shows only two commits to tracker: hrev30018 and hrev30033.
I think it could be hrev30033.

comment:2 by diver, 10 years ago

Unfortunately, my attempts to revert this change using this command

cd haiku/trunk/src/kits/tracker
svn merge -r 30033:30032 .

left libtracker.so in uncompilable state.

comment:3 by diver, 10 years ago

Version: R1/pre-alpha1R1/Development

comment:4 by diver, 9 years ago

Still here in hrev38262 on real hw using intel_extreme.

comment:5 by diver, 8 years ago

Description: modified (diff)

comment:6 by diver, 8 years ago

Cc: stippi added

I think this regression introduced in hrev30033. Stippi, could you have a look at it?

comment:7 by diver, 7 years ago

Still here in hrev43955. Dragging another tracker window above populating list shows that there is also a bug in the app_server.

by diver, 7 years ago

Attachment: screenshot1.png added

comment:8 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:9 by diver, 4 months ago

Still here in hrev53129.

comment:10 by diver, 4 weeks ago

Resolution: fixed
Status: assignedclosed

Can't reproduce anymore. Probably fixed in hrev53392.

Note: See TracTickets for help on using tickets.