Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#389 closed bug (duplicate)

KDL - VMWare (rev. 16961)

Reported by: mikael.konradson@… Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

KDL on boot.

Attachments (2)

HaikuKDL.png (45.2 KB) - added by mikael.konradson@… 13 years ago.
Stackcrawl
haiku_16975_PIII600_vm_page_fault KDL_on_boot.txt (22.9 KB) - added by umccullough@… 13 years ago.
Debug output w/KDL and stackcrawl

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by mikael.konradson@…

(From update of attachment 151) Iam getting this on every boot now.

comment:2 Changed 13 years ago by axeld

Did that change recently? Which version of VMware? Does changing the configuration help (there still seem to be a lot of happy VMware testers out there)? If so, what exactly helped the situation? :-)

comment:3 Changed 13 years ago by mikael.konradson@…

(In reply to comment #3)

Did that change recently? Which version of VMware? Does changing the configuration help (there still seem to be a lot of happy VMware testers out there)? If so, what exactly helped the situation? :-)

Yup, worked on friday, but doesnt anymore (Iam using the same VMware player). /Konrad

Changed 13 years ago by mikael.konradson@…

Attachment: HaikuKDL.png added

Stackcrawl

comment:4 Changed 13 years ago by j_freeman@…

The problem seems to be in the VMware image provided by Philipp Schmid and HaikuHost. If you grab the raw image instead and use QEMU to convert it to a VMware image, it boots fine without going into KDL.

comment:5 Changed 13 years ago by umccullough@…

Confirmed for me on real hardware: hrev16975

Machine spec is: ASUS P2B (intel 440bx) w/PIII 600mhz and 256mb RAM.

HD is on secondary master currently. I will switch it to primary master and see if that helps.

I will include debug output w/stackcrawl.

Changed 13 years ago by umccullough@…

Debug output w/KDL and stackcrawl

comment:6 Changed 13 years ago by umccullough@…

I went back to hrev16943 and starting applying changes to find out what change caused the issue.

It appears that hrev16945 works fine, but hrev16946 doesn't.

comment:7 Changed 13 years ago by umccullough@…

Same exact HD on hrev16946 boots fine in my SiS-chipset Via C3 machine - this would be hardware-specific then?

comment:8 Changed 13 years ago by axeld

Thanks for all the information!

* This bug has been marked as a duplicate of #393 *

comment:9 Changed 13 years ago by axeld

Resolution: duplicate

comment:10 Changed 13 years ago by axeld

Status: newclosed
Note: See TracTickets for help on using tickets.