Opened 13 years ago

Closed 11 years ago

#393 closed bug (fixed)

problems in device_manager

Reported by: korli Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver, umccullough, mikael.konradson@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When running rev16975 image in VirtualPC, I get the following stackcrawl.

Attachments (2)

ide_isa_dm_KDL.JPG (113.4 KB) - added by korli 13 years ago.
ide_isa publish_channel
haiku.txt (16.6 KB) - added by korli 13 years ago.
serial log

Download all attachments as: .zip

Change History (21)

comment:1 Changed 13 years ago by korli

The weird thing is : it happens when Haiku is on secondary slave. It doesn't happen when Haiku is on primary master or primary slave or secondary master.

comment:2 Changed 13 years ago by axeld

* Bug 389 has been marked as a duplicate of this bug. *

comment:3 Changed 13 years ago by axeld

Cc: mikael.konradson@… added

comment:4 Changed 13 years ago by axeld

I've now reverted hrev16946, does this help the issue? This seems to be a bug in the device manager, that I cannot reproduce.

comment:5 Changed 13 years ago by korli

I didn't test your change yet, but I'm wondering why the ide_isa module tries to publish its channels. The code

if (pnp->acquire_io_resources(resources, resource_handles) != B_OK) return B_OK;

in ide_isa:probe_channel() should return and nothing should get published since the pci ide driver handles the ide channels.

comment:6 Changed 13 years ago by axeld

Maybe it's first to acquire the resources, maybe there is some kind of race condition. In any way, it shouldn't crash either :-)

Feel free to investigate into this problem, that would be very much appreciated, since I cannot reproduce it :-/

Changed 13 years ago by korli

Attachment: ide_isa_dm_KDL.JPG added

ide_isa publish_channel

Changed 13 years ago by korli

Attachment: haiku.txt added

serial log

comment:7 Changed 13 years ago by korli

Resolution: fixed

comment:8 Changed 13 years ago by korli

Your revert to hrev16946 seems to have made the bug disappeared. It could also be a race condition indeed. I added some debug output in ide_adapter to know if it fails because of resource acquirement, and which one.

Anyway the crash is gone.

comment:9 Changed 13 years ago by korli

Status: newclosed

comment:10 Changed 13 years ago by axeld

Status: closedreopened

comment:11 Changed 13 years ago by axeld

Resolution: fixed

comment:12 Changed 13 years ago by axeld

Changed summary and opened it again, since the actual problem remains unsolved.

comment:13 Changed 13 years ago by axeld

Summary: crash in device_managerproblems in device_manager

comment:14 Changed 13 years ago by umccullough@…

I also will give this a try tonight to see if it resolves the issue I was having stated in #389

comment:15 Changed 13 years ago by umccullough@…

Cc: umccullough@… added

comment:16 Changed 13 years ago by umccullough@…

Yes, reverting the change from hrev16746 has resolved the crashing problem here also.

comment:17 Changed 13 years ago by diver

Cc: diver added

comment:18 Changed 13 years ago by marcusoverhagen

did hrev17619 change the behavior?

comment:19 Changed 11 years ago by axeld

Platform: All
Resolution: fixed
Status: reopenedclosed

Outdated.

Note: See TracTickets for help on using tickets.