Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#391 closed bug (fixed)

Audigy isn't detected.

Reported by: adamk@… Owned by: korli
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: umccullough@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have an SB Audigy (and an SB Live! that I've tried with), but it isn't initialized by the emuxki driver. The emuxki driver is present in /system/add-ons/kernel/drivers/bin, and there is a symlink to it in /system/add-ons/kernel/drivers/dev/audio/hmulti.

Attachments (1)

emuxki-failure.txt (58.4 KB ) - added by adamk@… 13 years ago.
Debug from the serial port.

Download all attachments as: .zip

Change History (14)

comment:1 by adamk@…, 13 years ago

bug_file_loc: http://68.44.156.246/emuxki-failure.txt.gz

by adamk@…, 13 years ago

Attachment: emuxki-failure.txt added

Debug from the serial port.

comment:2 by umccullough@…, 13 years ago

My SB Live! Value doesn't seem to get recognized either - which I assume uses the same driver.

comment:3 by korli, 13 years ago

the reason is : emuxki is dependent on the module "generic/mpu401/v1" which isn't published on the haiku image.

comment:4 by korli, 13 years ago

Status: newassigned

comment:5 by korli, 13 years ago

Could you check with revision 16976 ?

comment:6 by korli, 13 years ago

Cc: umccullough@… added

comment:7 by adamk@…, 13 years ago

It's now working... At least it's detected and plays an mp3. As soon as I hit ctrl-c, though, the machine locks up. Not sure if that's caused by the emuxki driver, though, or something else with the system.

Should the playfile crash be opened as a separate bug?

comment:8 by umccullough@…, 13 years ago

I would say yes - open a separate bug for the crash.

I will also test 16976 at home tonight with my SB Live and report back.

comment:9 by umccullough@…, 13 years ago

Definitely works now! As stated by Adam - playfile appears to have some issues

  • I was able to play at least one wav file with it, however.

I also successfully started up vlc to play some sound files and it had no problems playing some of the wav files that playfile crashed on.

comment:10 by korli, 13 years ago

Status: assignedclosed

comment:11 by korli, 13 years ago

Resolution: fixed

comment:12 by korli, 13 years ago

Would the crash only happen when doing Ctrl+C ? see http://www.haiku-os.org/bugzilla/show_bug.cgi?id=113 in this case.

comment:13 by umccullough@…, 13 years ago

For me, playfile crashed before even playing the wav files. I did not use Ctrl-C in my tests. It didn't crash into a debugger or anything - it only brought up the "terminating this application" dialog. I can provide the terminal output if that would be useful - but I think it warrants a separate bug.

I tried BeStartup.wav and BeBeep.wav that I copied to the Haiku disk from my BeOS Max v3 install - both failed. I grabbed another file from the same drive called boing.wav and it worked flawlessly.

All of them worked in vlc.

I just realized I didn't try SoundPlay like I was intending to.

Note: See TracTickets for help on using tickets.