Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4241 closed bug (duplicate)

[Tracker] dragging a file from LaunchBox over workspace replicant copies it and hides

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4280 Blocking:
Has a Patch: no Platform: All

Description

Start Workspaces and LaunchBox.
Drag any icon from LaunchBox pad over another workspace.
You should notice copy dialog and no file on Desktop.
Tested with hrev32411 under VirtualBox 3.0.4.

Change History (10)

comment:1 Changed 10 years ago by diver

Now I see that this file is just hidden under workspace window. Should this be closed as invalid, or something should be changed to prevent such situation?

comment:2 Changed 10 years ago by axeld

Do you mean by Workspaces a window or the replicant?

comment:3 Changed 10 years ago by diver

Sorry, I meant Workspaces replicant.

comment:4 Changed 10 years ago by aldeck

I've seen some code in icon placement that tries to avoid replicants, but it seems it's not working or not triggered in this case. I will take care of this in my branch. Concerning trunk, there are more urgent issues but a fix should be doable.

comment:5 Changed 10 years ago by diver

Summary: [Tracker] dragging a file from LaunchBox over another workspace copies it and hides[Tracker] dragging a file from LaunchBox over workspace replicant copies it and hides

comment:6 Changed 10 years ago by aldeck

Creating a new ticket as i would need to heavily modify the summary and description to be more generic, same for #4055 that i just found. I'll keep those for reference, and mark both as duplicate.

comment:7 Changed 10 years ago by aldeck

Blocked By: 4280 added

comment:8 Changed 10 years ago by aldeck

Blocked By: 4280 removed

comment:8 Changed 10 years ago by aldeck

Blocked By: 4280 added
Resolution: duplicate
Status: newclosed

Grouped bugs caused by similar problem. Marking as duplicate of #4280

comment:9 Changed 10 years ago by aldeck

Since hrev32523 one can use Cleanup to relayout hidden icons. That problem shouldn't happen when the new layouting is implement in my branch.

Note: See TracTickets for help on using tickets.