Opened 8 years ago

Closed 3 years ago

#4245 closed bug (fixed)

[Terminal] Preferences window is slow to appear

Reported by: diver Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Preferences window is slow to appear in hrev32432 in VirtualBox 3.0.4. Could be related to hrev32421

Change History (12)

comment:1 Changed 8 years ago by stpere

Owner: changed from jackburton to stpere
Status: newassigned

Hi, I would rather say it might be caused by another of my changes (ticket #4198). I optimized it in hrev32434. Can you tell me if it's better like this?

comment:2 Changed 8 years ago by diver

It's a bit faster now, but not that instant as before.

comment:3 Changed 8 years ago by stpere

further optimizations in hrev32435. Can you test again? Thanks

comment:4 Changed 8 years ago by diver

Sorry, but hrev32435 didn't change anything.

comment:5 Changed 8 years ago by jackburton

Can you try again with a more current revision ?

comment:6 Changed 8 years ago by diver

It's still slow in hrev34070.

comment:7 Changed 8 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:8 Changed 7 years ago by diver

Still here in hrev38828.

comment:9 Changed 6 years ago by Peter Polacik

Keywords: gci2011 added

The problem was checked during GCI 2011. I don't know, what slow actually means in this context, but on hrev43238 in VirtualBox 4.1.4, it takes around or little less than half a second (0.5s) to come up, so it doesn't seem like a problem anymore.

comment:10 Changed 6 years ago by diver

Well it's not that bad, but before hrev32225 it was instant.

Last edited 6 years ago by diver (previous) (diff)

comment:11 Changed 6 years ago by Chris Beiser

Still takes about three times as long as the pulse preferences window, which is pretty comparable other than the number of tabs, in hrev 43524.

comment:12 Changed 3 years ago by diver

Resolution: fixed
Status: in-progressclosed

Tried with VT-x turned off in VM settings and it seems to be fixed now.

Note: See TracTickets for help on using tickets.