Opened 10 years ago

Closed 9 years ago

#4292 closed bug (duplicate)

Using the menu key to open the Deskbar menu only works once

Reported by: mmlr Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4594 Blocking:
Has a Patch: no Platform: All

Description (last modified by mmlr)

When you try to use Haiku purely by keyboard you can use the menu key on the keyboard to open the Deskbar menu. When you hit it, the leaf button will get selected and the Deskbar menu opens. When you cancel the menu using escape, the menu will close, but the leaf button will stay selected. It is now not possible to open the Deskbar menu using the menu key again. You first have to click somewhere for the leaf button to lose its state, simply switching applications (with the twicher) doesn't resolve it either.

Change History (4)

comment:1 Changed 10 years ago by mmlr

Description: modified (diff)

comment:2 Changed 10 years ago by mmlr

Component: - GeneralApplications/Deskbar

comment:3 Changed 9 years ago by mmlr

Blocking: 7070 added

(In #7070) I've reported that in #4292 (and #4594 seems to be another duplicate just in a different context). That the mouse interferes with keyboard navigation is tracked in some other ticket as well I think. I'll close this as a dup of the former ticket in any case. Would be nice if this was fixed as it makes keyboard navigation way more useful.

comment:3 Changed 9 years ago by mmlr

Blocked By: 4594 added
Blocking: 7070 removed
Resolution: duplicate
Status: newclosed

This seems to be the same for menus in general as reported in #4594 as well. Closing this as a duplicate of that one as it is more general.

Note: See TracTickets for help on using tickets.