Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7070 closed bug (duplicate)

several bugs with keyboard-navigation

Reported by: smashIt Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/Development
Keywords: keyboard navigation Cc: 40043
Blocked By: #4594 Blocking:
Has a Patch: no Platform: All

Description

i noticed several bugs when trying to navigate through the start-menue with the keyboard

after pressing the menue-key, the start-menue opens when pressing it again, it doesn't close it pressing escape closes the start-menue (the menue-button is still drawn in a dark grey) pressing the menue-key now doesn't open it again

after giving fokus to another window, pressing the menue-key opens the start-menue again

when opening the start-menue with the menue-key, and the mouse-pointer being in a place where a menue-item appears, the mouse-pointer and the keyboard interfere with each other

a little demonstration: point the mouse where the applications-entry in the start-menue would appear on the screan press the menue-key the start-menue will open, and the mouse-pointer immediately opens the application-menue now you can navigate the application-menue with the cursor-keys, but you can't close it because the mouse-pointer opens it again

Change History (4)

comment:1 by stippi, 9 years ago

All these problems have already a ticket. This should be closed as duplicate when someone has the time to look up the older ticket(s).

comment:2 by mmlr, 9 years ago

Blocked By: 4292 added
Resolution: duplicate
Status: newclosed

I've reported that in #4292 (and #4594 seems to be another duplicate just in a different context). That the mouse interferes with keyboard navigation is tracked in some other ticket as well I think. I'll close this as a dup of the former ticket in any case. Would be nice if this was fixed as it makes keyboard navigation way more useful.

comment:3 by mmlr, 9 years ago

Blocked By: 4292 removed

(In #4292) This seems to be the same for menus in general as reported in #4594 as well. Closing this as a duplicate of that one as it is more general.

comment:4 by mmlr, 9 years ago

Blocked By: 4594 added

Seems closing the other one as a duplicate removed the blocked by, adding a direct blocked by to #4594 then.

Note: See TracTickets for help on using tickets.