Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4345 closed bug (fixed)

cannot mount USB sticks inserted after boot (r32645)

Reported by: rudolfc Owned by: anevilyak
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #4367
Has a Patch: no Platform: All

Description

Hi,

Sticks aren't seen when they are inserted after boot from a USB stick. They don't automount and they don't show up in drivesetup.

Tested BFS sticks only. Sticks inserted before boot from another USB sticks are seen and work.

Attachments (1)

SanDiskCruzerMicro (2.5 KB) - added by zaunpfahl 10 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by rudolfc

On the same system this worked OK for a long time now..

Oh, tested a boot with IDE and ATA manager: same behaviour.

Bye!

Rudolf.

comment:2 Changed 10 years ago by anevilyak

Component: - GeneralDrivers/USB
Owner: changed from axeld to mmlr

comment:3 Changed 10 years ago by anevilyak

Perhaps related to the recent changes with respect to device numbering?

comment:4 in reply to:  3 Changed 10 years ago by mmlr

Status: newassigned

Replying to anevilyak:

Perhaps related to the recent changes with respect to device numbering?

Unlikely.

Rudolf, can you provide a syslog from such a case? The same device works if plugged before boot, but not after? Does this only affect USB sticks or does it also affect other USB hardware? Maybe try un- and replugging a USB mouse if you use one to see what happens then. A log including such actions would be helpful to see if the basic detection still works or if the explore thread may have issues.

comment:5 Changed 10 years ago by rudolfc

Hi,

The syslog does not get any entries from plugging or unplugging the sticks. I'll doublecheck though, and try to do the mouse test.

The same device indeed works if plugged before boot, but not after.

Rudolf.

comment:6 Changed 10 years ago by anevilyak

Blocking: 4367 added

(In #4367) Duplicate of #4345.

comment:7 Changed 10 years ago by HaikuBot

I get the same with BFS and FAT sticks. If plugged before boot it works, if after - not.

comment:8 Changed 10 years ago by anevilyak

Just a note, binary searching this regression now. Will post when I have a rev nailed down.

comment:9 Changed 10 years ago by anevilyak

hrev32526 is the culprit, investigating.

comment:10 Changed 10 years ago by anevilyak

Owner: changed from mmlr to anevilyak
Status: assignednew

Problem understood, working on a fix.

comment:11 Changed 10 years ago by anevilyak

Fixed in hrev32820.

comment:12 Changed 10 years ago by anevilyak

Resolution: fixed
Status: newclosed

Changed 10 years ago by zaunpfahl

Attachment: SanDiskCruzerMicro added

comment:13 Changed 10 years ago by zaunpfahl

When I select "Mount", the popup freezes for a couple secs. Flash device ultimately not recognized. Worked flawless some weeks ago with the same hardware.

comment:14 in reply to:  13 ; Changed 10 years ago by anevilyak

Replying to zaunpfahl:

When I select "Mount", the popup freezes for a couple secs. Flash device ultimately not recognized. Worked flawless some weeks ago with the same hardware.

That's a completely unrelated issue to this ticket, please open a new one.

comment:15 Changed 10 years ago by rudolfc

Hi anevilyak,

Just tested a build from yesterday: the sticks are recognized again. Thanks!!

Rudolf.

comment:16 in reply to:  14 Changed 10 years ago by zaunpfahl

Replying to anevilyak:

Replying to zaunpfahl:

When I select "Mount", the popup freezes for a couple secs. Flash device ultimately not recognized. Worked flawless some weeks ago with the same hardware.

That's a completely unrelated issue to this ticket, please open a new one.

Ok. Ticket #4389

Note: See TracTickets for help on using tickets.