Opened 10 years ago

Closed 10 years ago

#4367 closed bug (duplicate)

KDiskDeviceManager::_ScanPartition is not called when connecting an USB hard drive

Reported by: oco Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4345 Blocking:
Has a Patch: no Platform: All

Description

I have enabled tracing in partitioning add-ons.

When i connect my USB hard drive to my old laptop, the raw partition is mounted but i can not see any new partition in the mount menu. Restarting the hard drive does not change anything. You can see this case by searching the first two "SAMSUNG" in the attached syslog.

Now, if i reboot while keeping the disk running, the partitions on the USB hard drive are not mounted. But then, if restart the hard drive, partitions are read. And the mount menu is populated with USB hard drive partitions. You can see this at the next two occurrences of "SAMSUNG". In this last case, KDiskDeviceManager::_ScanPartition is called.

In both case, the raw partition is mounted correctly (in /dev/disk/usb/...) as i can open and read it with diskprobe.

Tested in hrev32792.

Attachments (1)

syslog_USB_MOUNT (139.1 KB) - added by oco 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by oco

Attachment: syslog_USB_MOUNT added

comment:1 Changed 10 years ago by anevilyak

Blocked By: 4345 added
Resolution: duplicate
Status: newclosed

Duplicate of #4345.

Note: See TracTickets for help on using tickets.