Opened 10 years ago

Closed 10 years ago

#4368 closed bug (fixed)

Something seems wrong with retrieving revision information from libs

Reported by: anevilyak Owned by: anevilyak
Priority: normal Milestone: R1/alpha1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haven't yet ascertained an exact revision for this, but since at least a few days, AboutSystem and others seem to no longer be able to pull the name of the system (in my case it shows Unknown (Revision hrev32798). This problem is seen regardless of gcc version and also occurs on the alpha branch. I suspect it might have something to do with the changes related to getting libbe_test working since that's about when I last remember seeing correct data, will try and verify that shortly. Wanted to make a ticket so the problem isn't forgotten. Tagging as Build System for now until I have a better culprit narrowed down.

Change History (4)

comment:1 Changed 10 years ago by anevilyak

hrev32521 confirmed, investigating.

comment:2 Changed 10 years ago by anevilyak

More specifically it seems to be the Jamfile changes ; reverting only the Jamfile gives me a correct Walter (Revision 32799). However, looking at http://dev.haiku-os.org/changeset/32521#file7 I see nothing obviously wrong. Ideas?

comment:3 Changed 10 years ago by anevilyak

Owner: changed from bonefish to anevilyak
Status: newassigned

comment:4 Changed 10 years ago by anevilyak

Resolution: fixed
Status: assignedclosed

Fixed in hrev32800.

Note: See TracTickets for help on using tickets.