Opened 10 years ago

Closed 3 years ago

Last modified 13 months ago

#4402 closed bug (fixed)

Failure to boot on Intel i810 hardware

Reported by: vishy1618 Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_810 Version: R1/pre-alpha1
Keywords: Cc: pete.goodeve@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Testing Haiku on real hardware. I downloaded the latest(or whatever was yesterday) image (hrev32662) and dd'ied it into a spare 1 GB partition. Ran "makebootable" on it and added an entry to the Grub. When it starts, it shows color bars on the top left of the screen and for sometime the hard disk light flickers. Then nothing happens. I tried all safe mode options to no avail. Haiku just doesn't boot.

PC Config:

Intel i810 Motherboard 192 MB SD RAM Celeron 800 Mhz CPU 15" Samtron Monitor with max res. 800x600

I have attached the Onscreen Debug and Kernel Back trace images snapped with a camera.

Attachments (8)

03-09-09_0927.jpg (138.9 KB) - added by vishy1618 10 years ago.
OnScreen_Last.jpg (105.1 KB) - added by vishy1618 10 years ago.
BackTraceFirst.jpg (62.8 KB) - added by vishy1618 10 years ago.
The kernel panic message.
BackTraceLast.jpg (111.0 KB) - added by vishy1618 10 years ago.
Last Backtrace image.
Lys_Haiku_fail (42.9 KB) - added by Pete 9 years ago.
Boot failure debug output on i810
screenshot1.png (96.9 KB) - added by vidrep 3 years ago.
listdev (1.1 KB) - added by vidrep 3 years ago.
syslog (69.4 KB) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (32)

Changed 10 years ago by vishy1618

Attachment: 03-09-09_0927.jpg added

comment:1 Changed 10 years ago by vishy1618

EDIT: I am not able to attach the output taken as they are bot in excess of 488KB (4.8 MB total). They are a series of 45 images, so if there is any other way I could attach them then please intimidate.

comment:2 Changed 10 years ago by mmlr

You mention a backtrace, so does the kernel panic? If so you could transcribe the message and backtrace or you could post just the picture of that output. If it doesn't panic, the very last image would probably be the most useful, so you could attach that for now. If further info is needed, we can still request specifics later.

comment:3 in reply to:  2 Changed 10 years ago by vishy1618

Replying to mmlr:

You mention a backtrace, so does the kernel panic? If so you could transcribe the message and backtrace or you could post just the picture of that output. If it doesn't panic, the very last image would probably be the most useful, so you could attach that for now. If further info is needed, we can still request specifics later.

The kernel does panic, the message(when typing 'message in KDL) is "Double Fault". I will attach the last image of both back trace and onscreen debugging output.

Changed 10 years ago by vishy1618

Attachment: OnScreen_Last.jpg added

Changed 10 years ago by vishy1618

Attachment: BackTraceFirst.jpg added

The kernel panic message.

Changed 10 years ago by vishy1618

Attachment: BackTraceLast.jpg added

Last Backtrace image.

comment:4 Changed 10 years ago by mmlr

The first one is an app_server crash. Going from that I would guess it's a problem with the graphics driver. Combined with the "colored bars" it would seem to be a graphics card that has only very limited support for VESA. We might try to do something it doesn't support and fail to properly handle that case. VESA mode setting comes to mind for example. It's a bit hard to verify though without being able to specifically disable some features. Are you able to build Haiku yourself or do you have a way of accessing that BFS partition to put some files on it?

comment:5 in reply to:  4 ; Changed 10 years ago by vishy1618

Replying to mmlr:

The first one is an app_server crash. Going from that I would guess it's a problem with the graphics driver. Combined with the "colored bars" it would seem to be a graphics card that has only very limited support for VESA. We might try to do something it doesn't support and fail to properly handle that case. VESA mode setting comes to mind for example. It's a bit hard to verify though without being able to specifically disable some features. Are you able to build Haiku yourself or do you have a way of accessing that BFS partition to put some files on it?

I am on GNU/Linux so I'll see if there is any driver to mount the bfs partition. If you know of any then please tell. Thanks.

comment:6 in reply to:  5 Changed 10 years ago by mmlr

Replying to vishy1618:

I am on GNU/Linux so I'll see if there is any driver to mount the bfs partition. If you know of any then please tell. Thanks.

There is one, but it's readonly I think. If you have the resources and will you can of course set up a build environment and either build yourself or at least use the bfs_shell to access the partition.

comment:7 Changed 10 years ago by vishy1618

Hmm...I tried a lot, but could not get the befs driver working. I tried to search for BeOS Live CD but I could not get any images. All the links seem to be dead. If you guys know of a place to download the BeOS Live CD then please tell me. Then I can access the BeOS filesystem.

comment:8 Changed 10 years ago by vishy1618

I found this on the net:

Urias McCullough wrote:

On Wed, Aug 5, 2009 at 11:08 AM, Axel Dörfler<axeld@xxxxxxxxxxxxxxxx> wrote:

Which is actually the case, as we don't support window mode, we need a linear frame buffer. Now we could add support for this, but I don't think it's worth it.

Well, frankly (for those who previously found no good reason to write an i810 driver), if there is no other way to support video on i810-based machines, I think *some* solution should be considered - at least a native driver would give people some hope.

I will implement the Intel 810 driver, and hopefully it will take much less time to implement than the ati driver took.

That would be nice :) think I have one of thouse on my dell P3

That was on 2009-08. Is the driver completed? If not, what is its status? Is there any way I can help? I really want to get Haiku running on this hardware. I am totally dissatisfied with zeta. Thanks!

comment:9 Changed 10 years ago by vishy1618

Hmmm...I suppose that hope should be given up on this issue?

Any feedback would be appreciated!

comment:10 Changed 10 years ago by kvdman

vishy: here's a BeOS LiveCD:

http://www.haikuware.com/add-software/view-details/development/app-installation/beos-5-pe-max-edition

Not so sure it'll work on your hardware though.

comment:11 Changed 9 years ago by Pete

Cc: pete.goodeve@… added

I've bee unable to boot on my i810 machine, either, in this case using the alpha1 CD. There seem to be two distinct problems:

1) If I use the onboard graphics chips, I see the same problem as vishy -- colour bars in the top corner and nothing else. (Didn't have serial debug attached at the time, so I can't provide a log.)

2) I plugged in a Matrox Millennium video card, and finally saw the standard boot screen, but it would reach the 'rocket' icon, as if it was launching, but nothing further would happen.

I rearranged some cabling so I could get serial debug, and this is attached. (There seems to be some garbling at the start (bad serial sync?) but from then on it's complete.)

I really hope a solution can be found for this, as the i810 is the only box I'm likely to be able to use for Haiku in the near future, aside from the donated laptop (thanks Scott), which unfortunately has no net access...

Changed 9 years ago by Pete

Attachment: Lys_Haiku_fail added

Boot failure debug output on i810

comment:12 Changed 9 years ago by bonefish

A lot has changed since alpha 1, particularly concerning boot problems (e.g. new MTRR setup algorithm, and fixes for incorrect memory usage). Please try a current revision.

comment:13 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:14 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:15 in reply to:  13 Changed 8 years ago by Pete

Replying to scottmc:

Can you recheck this with a recent Haiku build? It may have been fixed recently.

Personally I can't I'm afraid. This particular machine is too old to boot from usb-stick, and I don't have a CD burner (or a spare partition on the drive). Be glad to know if others are successful, though.

comment:16 Changed 7 years ago by diver

Component: - GeneralServers/app_server

comment:17 Changed 7 years ago by umccullough

Component: Servers/app_serverDrivers/Graphics
Owner: changed from axeld to nobody

Actually, this is a video driver issue. I'm pretty sure the i810 doesn't properly support the newer VESA spec and will either require modifications to the VESA driver, support for "VGA" mode, or a proper modesetting driver (Gerald was considering writing on IIRC).

I have a couple machines with this chipset, fwiw.

Last edited 7 years ago by umccullough (previous) (diff)

comment:18 Changed 7 years ago by modeenf

Component: Drivers/GraphicsDrivers/Graphics/intel_810

comment:19 Changed 7 years ago by umccullough

May have been fixed with hrev44219. Please try a recent nightly image to confirm if the i810 driver works.

Note: the boot splash will still probably fail due to lacking VESA mode support, but the app_server should hopefully be able to use the i810 driver to get you a blue desktop.

comment:20 Changed 3 years ago by vidrep

Tested with hrev50525 x86_gcc2 Compaq Deskpro Workstation AP230 Haiku now boots to the desktop (screenshot1.png) However, some previously documented issues remain:

  • colour bars on top left of screen during boot (no Haiku splash with icons visible)
  • boot takes unusually long time
  • monitor native screen resolution (1680x1050@60Hz) must be set from screen preferences
  • only 16bit/pixel colour available
  • screen redraw is very sluggish
  • will not boot to desktop in fail safe video mode

listdev attached syslog attached

Changed 3 years ago by vidrep

Attachment: screenshot1.png added

Changed 3 years ago by vidrep

Attachment: listdev added

Changed 3 years ago by vidrep

Attachment: syslog added

comment:21 Changed 3 years ago by vidrep

The "Failure to boot on Intel i810 hardware" appears to have been resolved sometime in the past 7 years according to my recent test using this hardware. Should this ticket be closed, or should it be kept open until at least one other person verifies?

comment:22 Changed 3 years ago by vidrep

I would like to note that the Linux and MS i810 drivers both support 24 bit colour for this hardware.

comment:23 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: newclosed

I think Haiku supports only 16 and 32 bits, but not 24. Let's close the ticket and let this old hardware this way, I think we can say "good enough" for now?

The lack of bootscreen and failure to use VESA/FailSafe video is caused by an uncompatible VESA BIOS. We could work around it but it would need lots of efforts and there's not much point now that we have a native driver.

comment:24 Changed 13 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.