Opened 10 years ago

Closed 10 years ago

#4403 closed bug (fixed)

[LiveCD] Items are not removed after install

Reported by: Disreali Owned by: stippi
Priority: normal Milestone: R1/alpha1
Component: Applications/Installer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After I installed r1a1 hrev32907 from iso to disk, the files /boot/boot.catalog , /boot/haiku-boot-floppy.image, and folder /boot/rr_moved are not removed after install. Installed from iso to virtual disk on VirtualBox 3.0.4. Shouldn't there be a script to reove the 3 items?

Attachments (1)

haiku-r32907-LiveCD_install_files_not_removed.png (37.3 KB) - added by Disreali 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by stippi

Component: - GeneralApplications/Installer
Milestone: R1R1/alpha1
Owner: changed from axeld to stippi
Status: newassigned

comment:2 Changed 10 years ago by idefix

Shouldn't the Installer also remove its links on the Desktop and in the Applications menu?

comment:3 Changed 10 years ago by axeld

It actually does so (in the InstallerFinishScript). If that doesn't work, please file a separate bug report. OTOH I would like to keep the Installer in the applications menu.

comment:4 Changed 10 years ago by idefix

Ah yes I see, it's caused by the same error as I described in ticket:4063: missing quotes (the volume name had a space in it, causing those two remove statements to fail).
I will create a separate ticket for the patch later today.

comment:5 in reply to:  3 Changed 10 years ago by idefix

Replying to idefix:

I will create a separate ticket for the patch later today.

See ticket:4410.

Replying to axeld:

OTOH I would like to keep the Installer in the applications menu.

Yes, but then there should also be a link to Installer in the Applications menu on the VMware and raw images.

comment:6 Changed 10 years ago by Disreali

The original ticket issue is resolved by hrev32918. I believe this ticket may be closed resolved.

comment:7 Changed 10 years ago by stippi

Resolution: fixed
Status: assignedclosed

Thanks for the reminder!

Note: See TracTickets for help on using tickets.