Opened 10 years ago

Closed 7 years ago

#4406 closed bug (invalid)

graphic driver incorrect on HP Pavillion DV 4000 (Intel 91x chipset)

Reported by: l8night Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have tried both the alpha1 image and a build from svn (so I can test any fixes, or try things locally should the need arise). with both Haiku boots fine and runs, but in some places display colours are corrupted in the following ways. The Haiku logo on the desktop appears as if it's bit depth is wrong (you can read the letters but its a random rainbow of colours). the desktop background flickers and has some sparkly rainbow edges looks like the background of the screen are being used as heap! the lines around the windows are also corrupted, as are some fonts. the about this computer dialog is fine on the left, but unreadable on the right. but where windows render correctly they are fine and hide the corrupted background. and the resolution is correct at 1280x800

Windows XP says it's using the Mobile Intel 915GM/GMS,910ML Express driver

I have xubuntu, Windows-XP and Haiku installed on separate partitions (Haiku was build under xubuntu as a raw image and dd's onto the partition).

Is there anyway to turn off hardware acceleration or change to simple vga (I assume this is a driver issue as XP and Linux are fine). I'm happy to hack my drivers if you need more info etc.

Attachments (1)

syslog.zip (29.0 KB ) - added by l8night 10 years ago.
a zip of my syslog when booted and the intel extreme driver was loaded

Download all attachments as: .zip

Change History (11)

comment:1 by anevilyak, 10 years ago

Component: Audio & VideoDrivers/Graphics/intel_extreme
Owner: changed from marcusoverhagen to axeld

comment:2 by anevilyak, 10 years ago

If you hit space at the very beginning of the boot loader, you will get to a boot menu where you can pick fail-safe video mode, aka VESA.

comment:3 by l8night, 10 years ago

it is only 32bit mode that is the issue, I've just tried 1280x800 16bit and that's fine.

comment:4 by l8night, 10 years ago

that may not be 100% true .... if I press space and boot into save mode with a screen resolution of 1280x800@16bit and have selected fail-safe video then open preferences->Screen I can select 640x480,800x600,1024x768 and 1280x800 (native) resolution and bit depths of 8,16 and 32 (and they are all good) if I select a screen resolution of 1280x800@16bit but NOT check the fail-safe video option I see a similar issue as I do with the 32bit default. and the Screen preferences do no allow me to change resolution or depth.

comment:5 by umccullough, 10 years ago

fail safe video mode tells Haiku to use the fallback vesa driver instead. Thus, even if it supports the same resolutions, it's a different driver.

The boot splash screen always uses vesa (and whatever mode you tell it to use from the mode menu).

You can verify which driver/accelerant is in use once Haiku is running by using the following from a terminal with and without the fail safe mode on:

listimage | grep accel

which will generally show you which accelerant is being used by app_server

comment:6 by l8night, 10 years ago

in fail-safe (works):

/boot/system/add-on/accelerants/vesa.accelerant 0x82F000 0x833000 0 0

default (fails):

/boot/system/add-on/accelerants/intel_extreme.accelerant 0x82F000 0x83B000 0 0

comment:7 by l8night, 10 years ago

I rebuild the latest sources and enabled debugging on the add-on dir, I then booted in failsafe and cat /var/log/syslog contained this KERN: intel_extreme: init_hardware() KERN: intel_extreme: init_driver() KERN: AGP: bus manager init KERN: AGP: found 0 AGP devices KERN: intel_extreme: (0) i915GM, revision = 0x4 KERN: intel_extreme: publish_devices() KERN: intel_extreme: find_device() KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/graphics/intel_extreme KERN: Radeon - init_hardware: Version: 5.1.6.0 KERN: Radeon - Radeon_CardDetect: no supported devices found KERN: S3: init_hardware() - no supported devices KERN: vesa: init_hardware() KERN: vesa: init_driver() KERN: vesa: publish_devices() KERN: vesa: find_device() KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/graphics/vesa KERN: vesa: vesa_init() completed successfully! KERN: vesa: acc: vesa.accelerant

by l8night, 10 years ago

Attachment: syslog.zip added

a zip of my syslog when booted and the intel extreme driver was loaded

comment:8 by umccullough, 7 years ago

Does this still occur? There have been several updates to the intel_extreme driver in the past 3 years, and I know at least it works great on my i915-based machine.

comment:9 by l8night2, 7 years ago

you can close this then as I no longer have that laptop (and can't log in l8night any more!)

comment:10 by umccullough, 7 years ago

Resolution: invalid
Status: newclosed

You should be able to reset the password on your account, contact me privately if you need assistance with that (hopefully you can locate a method to contact me - it shouldn't be too hard :) )

Note: See TracTickets for help on using tickets.