Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#457 closed bug (duplicate)

[Pulse] "Deskbar mode" doesn't work...

Reported by: j_freeman@… Owned by: sikosis
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

(I doubt this is actually in Pulse, perhaps one of the servers or maybe even in the build system... so someone who's more intimate with the system can reassign this if need be.)

Anyway, selecting "Deskbar mode" in Pulse doesn't work: the Pulse window correctly disappears, but the activity bar doesn't appear in the Deskbar like it should.

I've seen screenshots where Deskbar mode is active and appears to be working, so this might just affect Linux builds (which is what I used for testing).

Also, every revision I can remember trying this in does this, so it's not a new bug.

Attachments (1)

pulse-deskbar.png (7.1 KB) - added by sikosis 13 years ago.
Pulse in Deskbar Mode

Download all attachments as: .zip

Change History (18)

comment:1 Changed 13 years ago by mmlr

This works for me on a BeOS build so I'd attribute this to the build system. What should we do with such bugreports?

comment:2 Changed 13 years ago by korli

Deskbar replicants don't work at the moment.

comment:3 Changed 13 years ago by j_freeman@…

(In reply to comment #1)

This works for me on a BeOS build so I'd attribute this to the build system. What should we do with such bugreports?

If the problem indeed lies in the build system, someone with adequate Bugzilla privileges can reassign this report from 'Applications/Pulse' to 'Build System'.

comment:4 Changed 13 years ago by diver

Cc: diver added

comment:5 Changed 13 years ago by jackburton

Component: ApplicationsBuild System

comment:6 Changed 13 years ago by sikosis

Tested in Build 17157. Appears to be working as per attachment.

comment:7 Changed 13 years ago by sikosis

Resolution: fixed

comment:8 Changed 13 years ago by sikosis

Status: newclosed

Changed 13 years ago by sikosis

Attachment: pulse-deskbar.png added

Pulse in Deskbar Mode

comment:9 Changed 13 years ago by j_freeman@…

Still doesn't work on Linux builds, only on BeOS builds.

comment:10 Changed 13 years ago by j_freeman@…

Status: closedreopened

comment:11 Changed 13 years ago by j_freeman@…

Resolution: fixed

comment:12 Changed 13 years ago by j_freeman@…

The plot thickens...

I popped in my BeOS 5.0.3 Pro CD in, and ran the Pulse that is on it... and Deskbar mode works just fine with it, yet the Haiku one still doesn't work.

comment:13 Changed 13 years ago by jackburton

Yes, it's expected. The Pulse on the beos 5 CD has the needed attribute (BEOS:SIG) which is missing from the one built on linux.

comment:14 Changed 13 years ago by j_freeman@…

Ah, okay... So is just Pulse affected, or do none of the apps have their app signatures when built with Linux?

If the latter is the case, then this bug report and #170 seem to actually be different symptoms for the same problem: that apps built on Linux don't get their signatures included.

comment:15 Changed 13 years ago by jackburton

Resolution: duplicate

comment:16 Changed 13 years ago by jackburton

* This bug has been marked as a duplicate of #170 *

comment:17 Changed 13 years ago by jackburton

Status: reopenedclosed
Note: See TracTickets for help on using tickets.