Opened 10 years ago

Closed 10 years ago

#4587 closed bug (fixed)

USB Stick can't be re-moutned

Reported by: Jason Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha1
Keywords: Cc: kallisti5, lurohh@…
Blocked By: Blocking: #4578, #5226
Has a Patch: no Platform: All

Description

Plug in USB-Stick. Mount stick. Unmount stick. Unplug stick. Plug stick back in. Can't find/mount it. Tried with two different USB-Sticks. Same result.

Have to reboot to fix.

Attachments (1)

output.txt (307.7 KB) - added by Jason 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by mmadia

Component: - GeneralDrivers/USB
Owner: changed from axeld to mmlr

Were you using Tracker, DriveSetup, or another method to unmount the disk?

Can you attach the output of listdev, listusb -v, and the contents of syslog after reproducing this? (`open /var/log/syslog')

comment:2 Changed 10 years ago by mmadia

possibly related to or duplicate of #4578 ?

Changed 10 years ago by Jason

Attachment: output.txt added

comment:3 Changed 10 years ago by Jason

Used tracker to mount/unmount usb sticks.

Happens with two different sticks; one Kingston and one Sandisk.

Hardware used: Acer Aspire One AOA-150 1555

Also does this on my regular machine as well.

Have to boot into windows to fix the problem on the Acer.

comment:4 Changed 10 years ago by umccullough

I have seen the same thing with my Kingston DataTraveler G2 sticks recently, which used to produce KDL mentioned in #4135

Note: I'm also using an AOA 150, but many other sticks I have work just fine.

comment:5 Changed 10 years ago by kallisti5

I saw the same issue on a BeFS usb stick with one partition (created in Haiku)

Plug usb stick.
Mount
Unmount
unplug usb stick
replug usb stick.
device shows up in /dev/.. but the partition does not show up in the tracker options...

another interesting thing, after the device shows up in dev and does not show up in the tracker you can run disk probe on the raw device (although have not tried it on partition) and cause a KDL...

last two lines of KDL (A1R1)

30 7ffeefac (+  48)  00105b1a    </boot/system/runtime_loader@0x00100000>:unknown + 0x5b1a
31 7ffeefdc (+   0)  7ffeefec    <2529:DiskProbe_main_stack@0x7efef000 + 0xffffec

I can get a full output if needed, but this should be easily reproducible...

As this is causing KDL on a fairly common procedure this should probably be a blocker for R1A2 as a minimum.

comment:6 Changed 10 years ago by kallisti5

Cc: kallisti5 added

@mmadia, it looks like this may be related to #4578 as per your comments.

comment:7 Changed 10 years ago by kallisti5

also looks like #3734 may be related.

comment:8 Changed 10 years ago by luroh

Cc: lurohh@… added

comment:9 Changed 10 years ago by luroh

Repeatable here with an NTFS formatted stick as well as a FAT formatted one. Doesn't happen all the time but it is repeatable. Revision 34872, gcc2.

comment:10 Changed 10 years ago by mmlr

Blocking: 4578 added

(In #4578) I'm going to close this one as a duplicate of #4587. If it actually is a duplicate then that it worked was pure chance.

comment:11 Changed 10 years ago by mmlr

Resolution: fixed
Status: newclosed

Fixed in hrev34967.

comment:12 Changed 10 years ago by mmlr

Blocking: 5226 added

(In #5226) Thanks for the update, closing.

Note: See TracTickets for help on using tickets.