Opened 9 years ago

Closed 2 months ago

Last modified 2 months ago

#4862 closed bug (invalid)

kernel panic when booting off CD iso

Reported by: brlcad Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I ran into a reliable kernel panic when attempting to boot up the R1/alpha iso on VirtualBox. I'd created a regular disk image intending to install to it. The CD image boots up normally, goes through initialization, and then promptly panics. At a glance through the bt, it looks like it crashed trying to scan the disk.

This is mildly related to bug #3955 / #3956

I did not verify whether a more recent build has the same problem as my next step was to merely download a current disk image, which worked fine.

Cheers! Sean

Attachments (1)

Picture 1.png (98.8 KB) - added by brlcad 9 years ago.
crash on boot off iso image

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by brlcad

Attachment: Picture 1.png added

crash on boot off iso image

comment:1 Changed 9 years ago by axeld

What version of VirtualBox are you using?

comment:2 Changed 9 years ago by axeld

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld

comment:3 Changed 9 years ago by brlcad

VirtualBox 3.0.8 hrev53138

comment:4 Changed 9 years ago by brlcad

Gah, got my tickets mixed up! This boot panic wasn't with VirtualBox -- it was with Parallels (2.5 Build 3214).

comment:5 Changed 9 years ago by axeld

Haiku is known not to work with Parallels. There is already bug #4561 which looks different, though. In any case, I would assume this to be a bug in Parallels.

comment:6 Changed 9 years ago by brlcad

For what it's anecdotally worth, I've used this same approach of booting this version of Parallels from an ISO CD disk image with Ubuntu, Solaris, and FreeBSD without issue.

comment:7 Changed 7 years ago by scottmc

Can you recheck this with a recent Haiku build and let us know if anything has changed?

comment:8 Changed 7 years ago by scottmc

Blocking: 7665 added

comment:9 Changed 7 years ago by Disreali

Looks to be a duplicate of ticket:4561.

comment:10 Changed 18 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:11 Changed 2 months ago by waddlesplash

Resolution: invalid
Status: assignedclosed

comment:12 Changed 2 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.