Opened 9 years ago

Closed 9 years ago

#4904 closed bug (fixed)

app_server crashes when starting Backgrounds prefs

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #4906
Has a Patch: no Platform: All

Description

This is hrev33893.

When starting the Backgrounds prefs, I get the attached KDL (that one's taken under VMWare). It's probably not really related to the Backgrounds prefs, please reassign to the right component if needed.

Attachments (1)

backgrounds-kdl.gif (14.2 KB) - added by humdinger 9 years ago.
KDL when starting Backgrouns preferences

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by humdinger

Attachment: backgrounds-kdl.gif added

KDL when starting Backgrouns preferences

comment:1 Changed 9 years ago by anevilyak

Component: Preferences/BackgroundsServers/app_server
Owner: changed from korli to axeld
Summary: KDL when starting Backgrounds prefsapp_server crashes when starting Backgrounds prefs

That's in fact not a kernel panic but an app_server crash.

comment:2 Changed 9 years ago by axeld

Status: newassigned

That looks like a regression I just recently introduced. Will look into it tomorrow.

comment:3 Changed 9 years ago by axeld

Blocking: 4906 added

(In #4906) Duplicate of #4904.

comment:4 Changed 9 years ago by streak

UPDATE: System will crash if You run "screenshot" app, aswell..

comment:5 Changed 9 years ago by streak

http://rapidshare.com/files/303140063/MVI_2710.AVI.html [ because ticket 4906 was closed, and maybe this video will help with solving the problem.. ]

comment:6 Changed 9 years ago by humdinger

Yep, the screenshoot shourtcut via Print key doesn't work and starting the Screenshot app results in the same crash. It looks exactly like your humongous video shows. :) Next time type "bt" for backtrace and compare to the vmware screenshot I attached. Should be identical.

comment:7 Changed 9 years ago by axeld

Resolution: fixed
Status: assignedclosed

Fixed in hrev33935.

Note: See TracTickets for help on using tickets.