Opened 10 years ago

Closed 5 years ago

#4907 closed bug (no change required)

New tag in forums not showing up on 2nd page

Reported by: richienyhus Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The orange "new" tag for new comments in topics on the forums is not showing up on the second and subsequent pages.

You can see this clearly when logged-in and viewing this topic.

Change History (3)

comment:1 by umccullough, 10 years ago

Not a new issue - I believe it has happened on every version of Drupal we have used so far.

It seems Drupal marks all comments as read once you've visited the node, regardless of whether they were on the first page or not.

in reply to:  1 comment:2 by koki, 10 years ago

Replying to umccullough:

Not a new issue - I believe it has happened on every version of Drupal we have used so far.

It seems Drupal marks all comments as read once you've visited the node, regardless of whether they were on the first page or not.

Yep, known Drupal problem; hopefully it will be fixed some day (but I would not hold my breath). In the meantime, I have increased the number of comments displayed per page to reduce the likelihood of this happening.

comment:3 by umccullough, 5 years ago

Resolution: no change required
Status: newclosed

Not sure if this is still a bug, but it's not something we are likely going to fix. Maybe Drupal will fix it in the future, or we'll migrate to a different CMS entirely.

The only other option I can think of is to not page the comments whatsoever, allowing an infinite number to load per page.

Note: See TracTickets for help on using tickets.